How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask bonzaco Your Own Question
bonzaco
bonzaco,
Category: UK Appliance
Satisfied Customers: 1417
Experience:  Owner at Dales Electronic
26760916
Type Your UK Appliance Question Here...
bonzaco is online now
A new question is answered every 9 seconds

Indesit IDL 605, we've had a few shots at getting it going

Customer Question

Indesit IDL 605
JA: I'll do all I can to help. How long have you been dealing with this?
Customer: we've had a few shots at getting it going -it went the 1st time but now it sits with the far left light flashing when it gets turned on
JA: Do you plan on doing the work yourself?
Customer: yes
JA: Anything else we should know to help you best?
Customer: not at this stage
Submitted: 15 days ago.
Category: UK Appliance
Customer: replied 15 days ago.
IDL 60s , sorry , NOT 605 !
Customer: replied 15 days ago.
I have to leave work now - the dishwasher is at work so I won't be able to work with it until Monday in New Zealand
Customer: replied 13 days ago.
what's happening with my query?
Expert:  bonzaco replied 12 days ago.

Hi my name is ***** ***** in the UK - left led flashing indicates that you have water in the base. If you remove the bottom kickstrip below the main door you will have access to the base area. With power off, old towell inside and dry it all out.

Customer: replied 11 days ago.
there's no water in the base. We have just got the machine (2nd hand) it did a whole cycle in the 1st place then it just sat there with the light going next time we tried it.
Customer: replied 11 days ago.
Hi - sorry to not get back to you earlier as just tilting the machine seemed to wake it up & it's going through the cycle - so far so good
Expert:  bonzaco replied 10 days ago.

Sounds like you did have water in the base which had activated the flood protection device, tipping it back has reset the system which explains why it now is working.