How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Kelly Your Own Question
Kelly
Kelly, Appliance Technician
Category: UK Appliance
Satisfied Customers: 19113
Experience:  Highly accurate diagnostician with over 30 years experience!
11418111
Type Your UK Appliance Question Here...
Kelly is online now
A new question is answered every 9 seconds

I have a Kenwood Dishwasher that has broken - I've had the

Customer Question

Hello I have a Kenwood Dishwasher that has broken - I've had the panel off and checked it isn't the door latch switch, this tests OK and I've tried disconnecting wires just in case but still wont respond to any of the top button presses
Submitted: 1 year ago.
Category: UK Appliance
Customer: replied 1 year ago.
I should add the main Power button is switching on fine, and the red power LED illuminating OK, but I'm not able to select any of the wash cycles, I just have "- - -" on the display. It does not appear to be the door switch
Customer: replied 1 year ago.
I have also tried pressing the power button in and holding the three buttons down, I think it then starts to cycle through each operation, starting at number 18, shut the door 17, doing various things like filling with water then draining as it counts down, but it appears to stop on number 10
Expert:  Kelly replied 1 year ago.

Hi, welcome to Just Answer. My name is ***** ***** I look forward to helping you! I suspect you will need to replace the main electronic control module.

May I please have your model number so I am able to provide you with accurate, model specific information?

Customer: replied 1 year ago.
KDW12ST3A - There are 3 PCBs inside the machine - one small board direct under the buttons, this clearly works as I can get it into diagnostics mode, 2 behind the external display on the machine - I suspect this is fine as it lights fully when powered on, but just flicks straight to "- - -" then the main PCB control board with relays etc on it, BUT what I don't get is why I'm not getting any "E" code....???
Expert:  Kelly replied 1 year ago.

The control is sold as an assembly, you get all 3 boards.

CLICK HERE

Customer: replied 1 year ago.
Hello - I purchased the boards and fitted them - the machine did exactly the same thing!!!!!!So tried holding the three buttons again - and it switched on showing "18" did various things down to "10" then stops. This obviously means something else wrong - what would it be doing at stage 10?
Expert:  Kelly replied 1 year ago.

I will open your question to other techs, I am not sure what would be causing the issue beyond the control assembly.

Customer: replied 1 year ago.
Anyone?