How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Kelly Your Own Question
Kelly
Kelly, Appliance Technician
Category: UK Appliance
Satisfied Customers: 20852
Experience:  Highly accurate diagnostician with over 30 years experience!
11418111
Type Your UK Appliance Question Here...
Kelly is online now
A new question is answered every 9 seconds

I have a beko dsfn1530b dishwasher that fills with water

Customer Question

Hi, i have a beko dsfn1530b dishwasher that fills with water but does not progress any further in its cycle. When i restart it, the water drains ok then refills. I have tested the circulation pump motor, capacitor and water heater and they are ok.
When i depress the start button and hold for 3 seconds then then turn the power on, all 5 of the lights on to of the door light up(solid lights).
To compound the problem, the machine has since run ok for the full cycle on 2 occasions but then stopped again.
Regards John.
Submitted: 1 year ago.
Category: UK Appliance
Expert:  Kelly replied 1 year ago.
Hi, my name is ***** ***** I look forward to helping you! The intermittent nature of the issue, in addition to the wash motor verified as good, would indicate an issue with the controller. The relay for the wash motor is probably faulty or the module is faulty. Either way, the module will likely need to be replaced. The part for your model is available below.
http://www.espares.co.uk/search/mo1387192/dishwashers/beko/dsfn1530b
Customer: replied 1 year ago.
Hi Kelly, thank you for your response. Would that be part number ES1570281 ? Is there a possibility that it may be the wiring harness?
Expert:  Kelly replied 1 year ago.
It could be, you can measure the voltage at the motor when it should be washing and see what you are getting. If absolutely no voltage, it is probably the module. Usually wiring issues will allow partial voltage and you would hear humming or buzzing from the motor.
Customer: replied 1 year ago.
I have just ordered a module. I will let you know the outcome when i have fitted it. Thank you.
Expert:  Kelly replied 1 year ago.
Sounds good, thank you!
Customer: replied 1 year ago.
Hi Kelly,
Just fitted new pcb...........still got the same problem. Any ideas?
Expert:  Kelly replied 1 year ago.
Has it run a full cycle at all as it did before?
Customer: replied 1 year ago.
Hi Kelly,
As before, i can select any programme, press start and the machine drains, fills with water and then stops. So i assume that it is waiting for a signal?
Expert:  Kelly replied 1 year ago.
It would seem so, yes. Odd that it worked a couple times before. That is almost always control related. Can you verify good wiring and connections to the components under the tub, paying close attention to the wiring where it bends around the tub at the bottom of the door?
Customer: replied 1 year ago.
Connections are good, not too sure about wiring. I will try and check it out. regards John
Expert:  Kelly replied 1 year ago.
Okay, keep me posted.
Customer: replied 1 year ago.
Hi Kelly, i have replaced the 2 PCB's in the door panel and checked continuity of the circulation pump wires, ok. There is no current at the circulation pump when the machine has filled with water. I am assuming therefore that a condition has not been made i.e water level etc. The water level reaches the bottom of the door and stops.