How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Rob Your Own Question
Rob
Rob, Home Appliance Technician
Category: UK Appliance
Satisfied Customers: 6991
Experience:  20 yrs. experience with a major worldwide manufacturer.
14831508
Type Your UK Appliance Question Here...
Rob is online now
A new question is answered every 9 seconds

i have a cannon oven 1043G. The fan stopped working (and caused

This answer was rated:

i have a cannon oven 1043G. The fan stopped working (and caused the power to trip off!) i've replaced this before, so thought would be a simple job again. Bought new fan assembly, fitted it, worked then stopped again! I watched it as i switched oven on, it seemed to want to move but it looked as if something was stopping it spinning!! Do you think the new fan is faulty as well?
Welcome, my name is XXXXX XXXXX I will be helping you with your problem today. If anything isn't clear, please just ask me.

You say that you replaced the fan, but did you replace the motor as well?

Thanks
Rob
Customer: replied 3 years ago.

Hi Rob, yes I replaced the whole unit, it's also a genuine cannon part from espares.com. I've replaced this part before, about 4 years ago!! I made sure that I replaced the connections exactly as they were removed.


 


regards - Steve

Hi Steve

Thanks

I am assuming that the grill, the oven element and the temperature neon on the fascia all still work? Please confirm this

The first thing to try is to remove the fan from the shaft inside the oven, then try and run it. Be careful of the element as it will get hot. Does the motor spindle turn or not?

Thanks
Rob
Customer: replied 3 years ago.

Hi Rob, No the spindle doesn't turn. I tried the old one & the new one. I also tried with them removed from the cooker (with the fan motor - no fan blade - sitting on the floor behind the cooker, just connected to the electrics - I always switch off & unplug first!!) that's when I could see that the spindle seems to jump forward & stop! Also, everything else works fine.


 


Steve

Hi Steve

We need to be sure that the motor is actually OK and not faulty.

Can you make up a test lead and connect 240volts directly to the motor. Ideally clamp the motor in a work bench. Does it work now?

Do you also have a multimeter?

Do all the other things I asked about , work correctly?

Thanks
Rob
Customer: replied 3 years ago.

Hi Rob, I've just clamped the motor unit in a vice & connected a direct 240v supply to it, switched on and........................ the spindle jumps forward slightly, but doesn't spin !!!! I suppose that means the NEW unit is faulty as well !!!!!!!!!!!


Everything else you asked about i.e, grill, light & neon, all working ok.


 


regards - Steve

Hi Steve

Well that is most unusual, but you are correct. The new motor is faulty.

I have been dealing with Espares for many years and never had a bad part from them. I guess in their defense, they don't make the part !

You will need to contact them and get it replaced, what a nuisance, still at least it means you are going mad !

If you need more help, please just ask me.
In the meantime,

Can I ask you to take a moment and rate my response? Please use the smiley faces which you should now see. Please remember you are rating me personally, not the website or the problems you have had with this machine.
If you need to ask me anything after rating, please just follow the link in the welcome email
Thanks
Rob

Rob and other UK Appliance Specialists are ready to help you