How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel T. Your Own Question
Daniel T.
Daniel T., Home Appliance Technician
Category: UK Appliance
Satisfied Customers: 14655
Experience:  25+ yrs. experience in white goods repair. NVQ Level 2 electronics manufacturers training courses.
Type Your UK Appliance Question Here...
Daniel T. is online now
A new question is answered every 9 seconds

I cannot start my automatic washing machine BEKO WM 6123 W

This answer was rated:

I cannot start my automatic washing machine BEKO WM 6123 W after turning it on. Buttons START/PAUSE/CANCEL, WASH and SPIN/END are solid green. I tried to reset the machine by using CANCEL button but it did not work. Can you give me advice what might be wrong? Thank you


Is the washer still full of water?

If so have you checked the filter in the bottom corner?

Take the plastic trim off and check the filter behind there and see if this is blocked up.

Let me know what you find.


Customer: replied 4 years ago.
The washer is empty. Yes, I did check the filter and the emergency drain hose. I drained them. There were lots of white small hard pieces in the water from the hose and the filter was clean. The START button flashes twice when I turn on the washer and after it stops.


Ok try this and see what happens.

Turn the dial to the cottons 90 deg cycle.

Then turn the washer off

Then press and hold the start button and with it held in turn the washer on.

Once the start light flashes let go of the button.

Then turn the washer off.

Then retry the washer and see what happens then.


Customer: replied 4 years ago.
Thanks for that. I did it and now only the START button flashes continuously.
Customer: replied 4 years ago.
Now the START button is solid green. Other buttons are not green.
Customer: replied 4 years ago.
I started the cycle and it is working. Thank you so much for your help.
All the best


Glad to hear you got it sorted.

Looks like it just needed resetting.


Daniel T. and other UK Appliance Specialists are ready to help you