How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Techdesk Your Own Question
Techdesk
Techdesk, Field Service Engineer
Category: UK Appliance
Satisfied Customers: 16407
Experience:  Whitegoods engineer working for a multibranded national company in the UK.
13782322
Type Your UK Appliance Question Here...
Techdesk is online now
A new question is answered every 9 seconds

I have a Flavel Milano 100 (ML10FRK). The fan oven and grill

Customer Question

I have a 'Flavel Milano 100' (ML10FRK). The fan oven and grill have stopped working. I believe I need a 'Thermal Fuse'. Where could I get one from, please?
Submitted: 6 years ago.
Category: UK Appliance
Expert:  Techdesk replied 6 years ago.

Hiya,

 

Did you post about this earlier today?

 

Thanks

Customer: replied 6 years ago.
no
Expert:  Techdesk replied 6 years ago.

Hiya,

Thanks for that.

 

I asked because I had an identical machine this morning with the same problem.

 

Depending on the build of your machine either a thermal fuse or a thermal cut out has been fitted.

 

Isolate the power to the appliance.

Disconnect it from the electrical supply.

 

Take the rear panel off and look for the thermal fuses or thermal cut outs.

 

Click here for pictures of the parts, you can also buy the parts here

 

There are 2 fuses or 2 cut outs on the machine.

 

Once you find them, you'll need to test them with a multimeter to determine which one has failed.

 

Replace it, try the machine again.

 

They blow/trip because they have overheated.

You'll need to check that the machine is working properly (oven thermostat etc) and isn't staying on causing the thermal to trip.

 

Hope this helps

Let me know how it goes or if you need more help

Thanks

 

Customer: replied 6 years ago.
I have removed the back panel and, found that there is 'charring' around the main cable carriage. This is internally, where all of the local wiring is attached. One of the spaded connections was found to be not connected. When I re-connected it, the fan oven and, grill, both worked OK. It seems as though the main carriage needs to be replaced. I'm not sure if it is called the 'main carriage', but hopefully you know what I mean. Do you know where I could get one of these from, please?
Expert:  Techdesk replied 6 years ago.

Hiya,

That would be the main connector block I think you're describing.

 

Click here for the part

 

Hope this helps

Let me know how it goes.

Thanks