How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Nathan Your Own Question
Nathan
Nathan, Installer
Category: TV
Satisfied Customers: 23577
Experience:  Custom home theater installer, authorized dealer top brands.
59725966
Type Your TV Question Here...
Nathan is online now
A new question is answered every 9 seconds

I recently switched the comcast's x1 system with my 70 inch

This answer was rated:

I recently switched the comcast's x1 system with my 70 inch Sharp aquos Model LC-706500u and my picture quality is not as good as before. I'm not getting a 1080 HD picture. It looks like is only 720. Have you seen this problem before.
JA: Can you guesstimate how old your Sharp is? And just to clarify, what's the exact model?
Customer: Yes it's 3 1/2 years old. Model LC-70c6500u.
JA: Does the TV menu work? Do you have the same problem on all sources/inputs?
Customer: Yes the TV menu works. I've tried all of the HDMI ports and I get the same problem. I previously used (two weeks ago) Comcast's non-x1 system and picture was fine. This only occurred when I made the switch to the x1 system
JA: How long has this been an issue? What happened right before this popped up?
Customer: See my previous message
JA: Anything else you want the TV expert to know before I connect you?
Customer: No, I guess that's it.

Hi, I'm Nathan.
Sorry to hear that you're having trouble, but I'll do my best to help you. Please give me a few moments to review your details here.

Have you gone into the comcast box's own setup menu (look for display/output) and set it to 1080p there?

Customer: replied 4 months ago.

Go into the settings on both the box and the tv, and disable the hdmi control (CEC) functions as well.

Customer: replied 4 months ago.
that didn't work. There's no difference in picture quality between the 720 setting and the 1080 setting.

Thanks for confirming,

this comes from a communication fault in the box not communicating properly with the tv, meaning it isn't identifying the sharp as a 1080p capable display.

These x1 boxes are a huge headache for us custom installers as they have glitches like this frequently.

The next step would be a reset process by doing the factory reset option within the sharp menu.

If that doesn't help we'll have to do a more involved manual reset next.

Customer: replied 4 months ago.
OK. Where is the reset on the sharp menu?

In the menu under Initial Setup, then Reset

Customer: replied 4 months ago.
Should I try this now?

Yes please do.

It will force you through all the initial setup again (channel scan, which you can skip, and setting language, wifi setup, etc)

Customer: replied 4 months ago.
Does this usually work. I'm willing to try this but I'm short on time tonight.

Typically yes it does.You can try it later and get back to me if needed.

Customer: replied 4 months ago.
Thanks. I'll try it tomorrow. How do I get back to you if needed

You're welcome. Just bookmark/favorite this page to reach me anytime.

Good luck!
Nathan

Customer: replied 4 months ago.
Ok. Thanks for your help Nathan.

You're very welcome.

Nathan and other TV Specialists are ready to help you