How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jack Your Own Question
Jack
Jack, Technician
Category: TV
Satisfied Customers: 8343
Experience:  40 years experience as audio,video repair and installation tech
39158752
Type Your TV Question Here...
Jack is online now
A new question is answered every 9 seconds

Sony KDL 50w700B'...TV has sound but no picture... i recent

Customer Question

sony KDL 50w700B'...TV has sound but no picture... i recent updated not sure if thats the problem and i had lots of rain not sure if it got hit my lightening
Submitted: 1 month ago.
Category: TV
Expert:  Anthony_Infotech replied 1 month ago.

Hello

Welcome

If you see any messages particular ones for a phone call they are not from me but the site, I do not use the phone call facility myself only this texting method which I consider the best way, if however you want to use the phone call option this will go to a board for another tech to take up, if a tech considers this viable by phone he will ring you, otherwise if you do not want it please ignore it thanks.

If you press the menu button of the sets own remote control does the menu come up please?

Can you see any visible light at all on the front of the set even in a darkened room?

Anthony

Customer: replied 1 month ago.
no menu ..but there is light on the screen
Expert:  Anthony_Infotech replied 1 month ago.

When you replaced the t-con board did you replace it using the part-number found on the original board itself?

Expert:  Anthony_Infotech replied 1 month ago.

Who provided the advice on replacing the t-con?

Customer: replied 1 month ago.
No the orginall Tcon on the white lable says 5550T20C11..... the part i got was 5550T20C08 ..both are KDL 50W700B
This was told to me by a service tech
Customer: replied 1 month ago.
are you there..
Expert:  Jack replied 1 month ago.

Hi , I`m Jack different tech. here

This service tech. was it a sony tech. or from that part supplier ?

Expert:  Jack replied 1 month ago.

What I`m getting at here is that although yes they both show as being for the model number KDL 50W700B , oftentime the panel version may have changed depending on the manufacture date and so will the t-con

In other words you can have 2 or 3 different t-cons for this same model number and it doesn`t mean they are subs to one another

Customer: replied 1 month ago.
ok...so in that case the one i got wasnt the correct one
Customer: replied 1 month ago.
well tell me should i then go find the correct board...i was also of the view that the main board could cause this problem... no picture but sound..
Expert:  Jack replied 1 month ago.

Could very well be and to tell you frankly I cannot find anything that says that those 2 numbers are subs either , hence my asking if this was from a sony certified tech.

It is my experience that when it comes to parts like the t-con there are not too many variations and the exact number is *****

Expert:  Jack replied 1 month ago.

Yes the main board could cause this but usually you will still have something like the OSD (volume bar , info etc.) or menu showing up

Customer: replied 1 month ago.
no this didnt came from a sony tech
Customer: replied 1 month ago.
well i dont have the menu or volume showing
Expert:  Jack replied 1 month ago.

I certainly would still suspect the t-con in this case

Expert:  Jack replied 1 month ago.

Only problem with t-cons is that there is no easy way of testing them beside trying them but here is something you can try

Expert:  Jack replied 1 month ago.

Unplug the LVDS cable , that is the lower connector that goes to the main board and while the tv is on plug it back loosely and wiggle it , if you see flashes or lines on then screen then this usually means the t-con is still active although this is a rough test

Customer: replied 1 month ago.
The Back lights are on and there is sound ...just no picture.... so there is light on the screen
Expert:  Jack replied 1 month ago.

Yes I got that at the beginning and so it does point to the t-con , I would`ve had the same diagnostic as you .

Expert:  Jack replied 1 month ago.

Its just that different part number that bugs me here .

The last letters and numbers are usually the ones that gives you the version

Customer: replied 1 month ago.
in so getting the correct board would i need to follow all the numbers and letters on the white sticker?
Expert:  Jack replied 1 month ago.

That's correct , all the letters exactly

Customer: replied 1 month ago.
its like 26 in total
let me show you what this is
Expert:  Jack replied 1 month ago.

I meant that this number 5550T20C11 was good , just the finish did not match

Customer: replied 1 month ago.
Fx-5550T20C11(###) ###-####NOP(###) ###-####
Expert:  Jack replied 1 month ago.

You need that C11 number

Expert:  Jack replied 1 month ago.

its actually FX-5550T20C11

Customer: replied 1 month ago.
i havent been able to find the part.... not by that number.... just finding it hard...i have already bought 2 wrong boards
Expert:  Jack replied 1 month ago.

Yes , I was looking for it myself and no suppliers .

Best I could suggest would be to either contact a local sony ASC/repair shop and have them order it for you direct from sony but that wont be cheap and that is if it is available , most sony t-con`s have been harvested and sony does not sell them separate , they are part of the lcd panel

Other option would be to set an alert on ebay for that part number

Expert:  Jack replied 1 month ago.

Let me know if you have other questions and if not for now then please do take the time to rate by clicking on the star icons at the top of your page, then click on Submit so i get paid for my time helping you .
Also note that it will not close this post , you can come back here at any time if you need further info or help .
Thank you

Customer: replied 1 month ago.
then in summary jack ...your feelings would be the Tcon board
Customer: replied 1 month ago.
i really thought of the main board...and not the tcon
Expert:  Jack replied 1 month ago.

Go ahead with the main board if you wish but before you do , re-install the original t-con and try that test I told you above

Expert:  Jack replied 1 month ago.

Any questions on this ?
Remember that you can come back here at any time after rating (no additional charges) if you have other questions related to that