How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jack Your Own Question
Jack
Jack, Technician
Category: TV
Satisfied Customers: 9131
Experience:  40 years experience as audio,video repair and installation tech
39158752
Type Your TV Question Here...
Jack is online now
A new question is answered every 9 seconds

Toshiba 55VL900A LCD TV had black screen (lit) but no menu

Customer Question

Toshiba 55VL900A LCD TV had black screen (lit) but no menu etc. or image and no audio. I am an amatuer but tried some trouble shooting. Before ordering a new D-con board or main board (can't remember their real names from youtube fix it videos) thought I would test a few other things. The remote light does not come on when pressing buttons. Don't know how or where to test the remote bits. Batteries Ok. Stand by voltages on TV seemed good. Back lights were good until I tried testing a fuse and touched the part next to it and wham!!! Now I have no back lights either. Not real good at testing fuses. (Don't know how to get the right setting on my volt meter).Help - Please?
Submitted: 7 months ago.
Category: TV
Expert:  Jack replied 7 months ago.

Hi , I`m Jack and I will be helping you today
Please note that I am an independent audio/video tech. that depends on your positive rating to get paid by this website and I have no control over the phone (or other) offers , they are sent by the website ,not by me but let me know if you`d rather do this on the phone.
That being said , a few questions coming up ;
Please let me know when you are ready to proceed .

Expert:  Jack replied 7 months ago.

What is the tv doing now if anything ?
Is there a light or blinking light at the front , clicking sound from inside when you plug in the power cord or try to turn it on ?
Or completely dead no activity whatsoever (as I suspect) ?

Customer: replied 7 months ago.
TV clicks when power is turned on. But no longer have a green light or Toshiba symbol. Suspect when I shorted it blew some fuses.
Customer: replied 7 months ago.
Are you still there?
Expert:  Jack replied 7 months ago.

Yes , I need time to type

Some fuses or worse depending on what you shorted .

The fuse (s) if more than the main fuse which is obviously good as you have some power are usually on the pimary side and usually there is only one in those TV's so you would not be looking at a bad fuse .

Haven`t found any parts (yet) for this model but then parts seem to be a rare convenience on your side of the ocean.

Can you upload a close-up picture of your power board ?

Customer: replied 7 months ago.
Where do I send the photo?
Expert:  Jack replied 7 months ago.

Can you see a paper clip icon above the window you type in ?

That is to attach files like pictures

Give me a minute

Customer: replied 7 months ago.
there is an add files icon but prefer to send it straight from my iphone if i can?
Expert:  Jack replied 7 months ago.

No idea how you can do that from your phone but if yu are talking to me via your phone then i suppose you can

Sorry but this tv repairman is cell phones dumb

Customer: replied 7 months ago.
I'm not much better. I am sorry but I don't think this is going to work. But thanks for your time.
Expert:  Jack replied 7 months ago.

Right now I`m sorry to say but you may be in over your head with this project and you may need the help of a local repairman on this .

There is a chance though that this may be a blessing in disguise ,

What I mean is that now you officially have a defective power board and there is a chance that it also was the one causing the original problem i.e missing voltages to the main and t-con board that caused the loss of pcture and sound .

Expert:  Jack replied 7 months ago.

This would have to be verified though and if you were to go further with this then simply replace that power board , you`re going to need one anyway and it might fix everything

Customer: replied 7 months ago.
Tested the fuse which was faulty and replaced it. Now back to original issue. Backlights good. Standby light on. Remote (not functioning). Audio is out. Have tested standby voltages from Main Logic Board to main Voltage Board - seems according to spec. How can I know for sure whether it is Main Logic Board or T-Con board as main Voltage board seems Ok?
Expert:  Jack replied 7 months ago.

Hi again

Too hard for me to tell from where i`m sitting , you may have to just give it a try , i have ZERO data on this model , can even see or get a picture of it

Sorry but that is pretty much it from my end