How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Shahid Your Own Question
Shahid
Shahid, Technician
Category: TV
Satisfied Customers: 10662
Experience:  I have been repairing electronic gear since 1993 as a qualified Sony tech
33243543
Type Your TV Question Here...
Shahid is online now
A new question is answered every 9 seconds

LG plasma, model 60PA5500. When its turned on(or turned off,

Customer Question

LG plasma, model 60PA5500. When its turned on(or turned off, cant tell), it clicks, and the power indicator is solid red and when the power button is pressed again, it blinks red twice then no light at all. Picture wont come up. I unplugged the SC and the SS boards, and it still clicks. Need troubleshooting to find the bad board, and hopefully down to one particular IC
Submitted: 8 months ago.
Category: TV
Expert:  Shahid replied 8 months ago.

Hi, my name is ***** ***** I will do my best to help you today. To make sure I don’t miss anything, please give me a minute to review your question.

Expert:  Shahid replied 8 months ago.

Hi Ed, can you check Va and Vs volts on P811 connector of power supply board?

Customer: replied 8 months ago.

Output to SC and SS had steady 200something volts, and steady 50something volts, also steady 5v, cant remember the rest of the readings....i DO remember that the problem indicator had voltage. But just let me know what all to test, and when I get home from work here in 6 hours, I will test all of it.

Expert:  Shahid replied 8 months ago.

Volts you're getting is correct, check Va and Vs while SC and SS boards disconnected then connect the boards and again check, if volts drops then either SC or SS board would be defective. Please reply back with the result to proceed.

Thanks.

Customer: replied 8 months ago.

VS 202.8-203.1, no change plugged or unplugged for either SS or SC. VA 54.5-54.7, no change plugged or unplugged for SS or SC.

Expert:  Shahid replied 8 months ago.

OK, do you have similar SC board to replace it in TV?

Customer: replied 8 months ago.

I can look, but i doubt it. If I do, it's not verified good.

Expert:  Shahid replied 8 months ago.

OK, other TV might have different issue so verify this SC board in that TV?

Customer: replied 8 months ago.

I can look and see if i have a matching one. I thought you said we were looking for a drop in voltage, though...and it did not drop

Expert:  Shahid replied 8 months ago.

Oh yes, that volts drop will occur if board is short and if board is open/ not short then volts will stay same but screen wont get required volts/ pulses to illuminate, it seems SC board isn't working thus screen stays dark, other possibility is if screen is broken/ cracked that can cause such symptoms.

Customer: replied 8 months ago.

Can i test the output from SC board to see if its getting required pulses?

Expert:  Shahid replied 8 months ago.

I wish there was such test available, board replacement is only option here my friend to verify the board, once you figure out bad board then can check the components/ FETs/ fuse/ resistors to find out what is bad in defective board.

Customer: replied 8 months ago.

Ah, gotcha. And SC is the y-sustain?

Expert:  Shahid replied 8 months ago.

Correct, y-sus board on left side is SC.

Each brand has its own name for that board, on right side board some calls it SS, some calls it z-sus, some calls it x-main etc.

Customer: replied 8 months ago.

If I replace it, and the buffers, and theres no change...could any other boards be causing the problem? I had this problem with another LG, was turning on, then right back off...I replaced the y-sus and power and still have the problem...

Customer: replied 8 months ago.

This one, the guy i bought it from said it stopped working after they transported it from one town to another....was in between mattresses, etc, well cushioned.

Expert:  Shahid replied 8 months ago.

If screen shows light/ glow and then TV shuts Off that means sustain boards are at least working and problem is some where else. IT could be failing power supply or main board or logic control board etc.

Expert:  Shahid replied 8 months ago.

Shine a flashlight on screen to find any crack on it, if found one then screen is broken.

Customer: replied 8 months ago.

No light at all....tv never loghts up...and it doesnt shut off, either...stays on...no indicator light on the front, but on the main board in the back i have a red LED, LD500. im not sure which is on, and which is off..when i have a solid red light on the front, there is no red LED in the back...when i hut the power button, the red indicstor in the front blonks twoce, then theres no light at all in the front, but thats when i get the red LED on the main board in the back.

Customer: replied 8 months ago.

No light at all....tv never loghts up...and it doesnt shut off, either...stays on...no indicator light on the front, but on the main board in the back i have a red LED, LD500. im not sure which is on, and which is off..when i have a solid red light on the front, there is no red LED in the back...when i hut the power button, the red indicstor in the front blonks twoce, then theres no light at all in the front, but thats when i get the red LED on the main board in the back. And when the indicator in frontis off, and led on back is on, I hear a faint buzzing coming from both the SS and the SC boards.

Expert:  Shahid replied 8 months ago.

It seems sustain boards are not working and main board LED flashing to report an error. Swap the sustain boards (y-main and later on x-main, if required) to verify the screen and rest of TV.

Customer: replied 8 months ago.

The LED on the main board is solid red, not flashing

Expert:  Shahid replied 8 months ago.

I think the LED flash once in normal operation, means no error. Solid LED is also reporting an error.