How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jack Your Own Question
Jack
Jack, Technician
Category: TV
Satisfied Customers: 8343
Experience:  40 years experience as audio,video repair and installation tech
39158752
Type Your TV Question Here...
Jack is online now
A new question is answered every 9 seconds

Sound but no picture, samsung 50' plasma, failed a few days

Customer Question

sound but no picture, samsung 50' plasma
JA: How long has this been going on?
Customer: failed a few days ago
JA: What troubleshooting have you tried?
Customer: looked at Vs, Va adn Vsc, VS looked normal, other two looked a little low
JA: The TV expert can solve this for you. Anything else you want him to know before I connect you two?
Customer: I the expert TV Tech1?
Submitted: 3 months ago.
Category: TV
Expert:  Anthony_Infotech replied 3 months ago.

Hello
Welcome

I am just reviewing the question be back in a min

Anthony

Expert:  Anthony_Infotech replied 3 months ago.

TV Tech 1 is not available sorry hopefully I can help, can you get me the model number please found on the back of the set?

Customer: replied 3 months ago.
pn50B530s2fxza
Expert:  Anthony_Infotech replied 3 months ago.

Sorry I have to go on a call will open this to others

Customer: replied 3 months ago.
Well, that's disappointing.
Expert:  Jason Jones replied 3 months ago.

Hello,
I am the person that will be helping you today.

What kind of input are you using with the Samsung Device? Examples may be: HDMI, RCA, Cable Box, Antenna, etc.

I will be standing by, looking forward to your response.

Thank you,
Jason

Customer: replied 3 months ago.
I currently have it connected to a Blu-ray player via HDMI. When it failed the other day, it was connected to a Yamaha AV receiver and my son was using his PS4 at the time, which was connected through the receiver - the picture failed before his eyes. It now behaves the same way connected directly to the Blu-ray player. I have not attempted another type of video input.
Expert:  Jason Jones replied 3 months ago.

Thank you for the update. Generally speaking, when a board fails on such types of sets, you will lose both the video and audio. Being that only the video went out, it sounds as though either the video cable is loose or the screen itself has failed. Have you opened the device and verified that the video cables are securely in place?

Customer: replied 3 months ago.
I have opened the device. The ribbon cables connected to the Y-buffer board all appear to be securely in place. The same is true for the ribbon cables connected to the X-Main board. Yesterday I disconnected the X-main and turned on the TV. The room was somewhat dark and I saw a brief show of color when I heard what I assume is a relay energizing (same sound it always makes when turned on) - lasted less than half a second.
Expert:  Jason Jones replied 3 months ago.

I have run out of ideas.

For this reason, I am opting out of the question and allowing another expert the chance to help.

The next expert will see all that is on this page, so there will be no need to repeat anything.

When another expert picks this up, you will be notified by email.

Thank you for your patience.

- Jason

Customer: replied 3 months ago.
Ok, thanks.
Expert:  Jack replied 3 months ago.

Hello , I`m Jack , yet another tech.

Still need help with this ?

Customer: replied 3 months ago.
I still need help. Thanks.
Expert:  Jack replied 3 months ago.

O.k then I was looking at this and especially the part where you said that the x-sustain did make a difference when unplugged .

It is my experience when those plasma still turn on and have sound that usually the X-sustain board is defective .

Any other boards going defective in those and the tv is simply dead and sometimes a blinking light at the front

There are 3 versions of it for your model and you would have to ID yours before ordering , check the link below;

http://www.shopjimmy.com/catalogsearch/result/?q=pn50B530

.

Expert:  Jack replied 3 months ago.

You can click on the pictures for more details .

If that answers your question please do not forget to rate by clicking on the star icons at the top, then click on Submit so i get paid for my time helping you .
Also note that it will not close this post , you can come back here at any time if you have questions.

Customer: replied 3 months ago.
OK, so you're recommending I change the X main board. Fair enough, I'll give it a try. I tried to send a photo showing the part number on the board but it won't go through. Fortunately, the part number on the board matches the board number on the link you sent me from shopjimmy. It should take a few days to get the board. I'll consider this case closed after I get the TV fixed. Thanks.
Expert:  Jack replied 3 months ago.

No problem , have fun and take your time with it

Customer: replied 3 months ago.
I replaced the X-main board - no change, still have sound, but no picture. Any more ideas?
Expert:  Jack replied 3 months ago.

Quite surprised here and i think its time to have a local tech. to take a look at it , this needs a hands on ( with meters) approach now

Expert:  Jack replied 3 months ago.

I will opt out as well now

Customer: replied 3 months ago.
Well, thanks for trying. I have my own meters and don't intend to call a local tech.