How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Louie Your Own Question
Louie, Technician
Category: TV
Satisfied Customers: 2557
Experience:  25+ yrs. experience in the field and 5+ yrs. online, down to component level.
Type Your TV Question Here...
Louie is online now
A new question is answered every 9 seconds

I have a Hitachi P50S601 TV that has the red standby light

Customer Question

I have a Hitachi P50S601 TV that has the red standby light only. I replaced two bulging caps on power supply board (100v 3300uf (m). The TV still does nothing.The only power I get on the entire board is the 15 pin CNPPS on the three bottom pins (5.4) ea. I have checked for voltage on CN99, and the three pin socket to the left. can you help?
JA: Can you guesstimate how old your Hitachi is? And just to clarify, what's the exact model?
Customer: It is eight yeas old and the model # is P50S601.
JA: What troubleshooting have you tried?
Customer: Replaced the bulging 100v 3300 uf caps and check board for any kind of volage. I do know it getting 120 volts to the set.
JA: The TV expert can solve this for you. Anything else you want him to know before I connect you two?
Customer: no, Thank You!
Submitted: 2 months ago.
Category: TV
Expert:  Anthony_Infotech replied 2 months ago.



Does the set still have the red standby light lit?you cant unlock it from standby either with the remote or at the set itself?

Secondly you are sure your work is good you fitted the correct value capacitors and also they are the right way oriented on the board (because they are polarized)?


Customer: replied 2 months ago.
I can get the blue on light to come on if I hold in the power button for 20 sec, or till I hear a click. The remote does nothing. I checked both of the new caps before installing them. Yes they are installed correctly. I was aware there is a positive and a negative.
Expert:  Anthony_Infotech replied 2 months ago.

OK please just give me 5 mins whilst I go through the data for this set

Expert:  Anthony_Infotech replied 2 months ago.

OK you still may have a problem with the power-board however these sets suffer greatly from bad COF chips on the two buffer boards you see those boards with all the postage stamp type chips on?there is about 8 chips on each board let me know you see this first

Customer: replied 2 months ago.
I see the buffet boards on the left side. They all look to be good.
Expert:  Anthony_Infotech replied 2 months ago.

No you need to get the buffer boards out of the set, you need to get the chips under a magnifyer and you need a strong light on the chips you need to check each chip individually looking for tiny pin holes in the chips let me know if you spot any

Customer: replied 2 months ago.
Took the buffer boards out and looked at them under a light and magnifying glass. Look good. Also checked continuity on pins two and 6, 20 and 24, 28 and 30, and 36 and 50. No short found.
Expert:  Anthony_Infotech replied 2 months ago.

The Vs and Va on the power-board does that come up?or come up and die away?

Customer: replied 2 months ago.
Where do I find this?

Related TV Questions