How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Master Fix It Your Own Question
Master Fix It
Master Fix It, Technician
Category: TV
Satisfied Customers: 8997
Experience:  25 + Years experience repairing TVs, VCRs Computer etc.
Type Your TV Question Here...
Master Fix It is online now
A new question is answered every 9 seconds

I have a Control 4 HC-300 that froze up last night. I had to

Customer Question

I have a Control 4 HC-300 that froze up last night. I had to disconnect power to turn it off. Now I can't get it to respond at all. The only thing I can get to light up is the power light.
I have removed the batteries from the remote, unplugged the unit several times, and rebooted with the identify button several times. The wifi light will blink after these maneuvers, turn solid for about 5 seconds, then turn off again.
Any suggestions? Thanks in advance.
Submitted: 3 months ago.
Category: TV
Expert:  Russell H. replied 3 months ago.

Hi, thank you for contacting My name is Russell. I will do my best to provide the right answer to your question.

Try checking as to the status of your wireless router, and whether its indicator lights show normal status.

Also, turn the wireless router Off, and leave it Off for 10 minutes. Then turn it On again, then let it initialize for 2+ minutes.

Then try booting up the Control 4 HC-300 again, and see if its operation differs any.

If not, then it might possibly be 'broken'. Is it protected by a surge protector? on its power connector?

Customer: replied 3 months ago.
Thanks Russell. I tried those suggestions earlier, to no avail. The router and Internet are working normally, and there are surge protectors on the system. Are you familiar with the Control 4 system? It automates most of our cabin, and is direct wired to the entertainment components, each with their own dedicated IP address.The system is not broken, as I can still control everything else in the cabin. This seems to be a glitch with just the upstairs entertainment system.
Expert:  Russell H. replied 3 months ago.

The upstairs is connected to the Control 4 box by wireless then, I take it?

I'm not terribly 'up' with Control 4 systems, so if you prefer, I will Opt Out of this case and open it to other Experts.

Customer: replied 3 months ago.
No, hard wired. Complicated system, have about $20 k invested in it.
Expert:  Master Fix It replied 3 months ago.

Hi I saw the problem you are having ad I understand these Control4 systems well as I use them myself .

What Happened is that the software became corrupt and given the complexity of your system, unfortunately you will need to call an AT guy in, Most local computer shops can fix this for you as well as Best Buy Geek Squad.

I would call Best Buy and schedule an in home ticket with them. They are fair priced and should be able to fix it right up for you. I know I used to work for them lol

In any case, I will stick with you until this is complete.

Please rate my service kindly.

Also it is the only way I am credited for my time and expertise with you.

Once you rate, I will be notified and will add your question to my priority list so you can reach me anytime until this problem is solved.

Then you can reach me by simply replying to this message anytime.

Thank you and have a great weekend!


Tech Michael

Customer: replied 3 months ago.
Thanks Michael,I did get a response from the company that did the installation and they seem to think that the power adapter died. When logging into my router, I can see that 4 of the hard wired connections are now missing. Does that make any sense? It is the power adapter, would the indicator lights on the system still work?
Expert:  Master Fix It replied 3 months ago.

Hi YES that sure does ;-)

SO it may be all you need. Let me know if you need a source or if they will send you out a new adapter transformer. Transformers are great when left powered, but when you disconnect them the varnish coated wires crack and short out ;-(

Just the nature of the component unfortunately.

That will likely fix this one. Let me knwo if you require any assistance when you get the new adapter or of you need me to find one for you online ?

Please rate kindly at this time so I can remain with you until we are sure this is fixed properly;-)

Thank you and have a wonderful weekend!

Tech Michael