How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Master Fix It Your Own Question
Master Fix It
Master Fix It, Technician
Category: TV
Satisfied Customers: 9135
Experience:  25 + Years experience repairing TVs, VCRs Computer etc.
11519491
Type Your TV Question Here...
Master Fix It is online now
A new question is answered every 9 seconds

Mitsubishi Model LT46244 Dead, No Lights

Customer Question

Mitsubishi Model LT46244 Dead, No Lights
Submitted: 6 months ago.
Category: TV
Expert:  Jack replied 6 months ago.

Hi again Willie, this is Jack

Expert:  Jack replied 6 months ago.

Looking at that chassis , this is a bit different than what you usually get as far as standby voltage goes.

This one has a standby 12 volts instead of the standard 5 volts on the power board .

This 12 volts is sub-divided into 5 and 3.3 volts on the main board so that is where it sts and obviously right now it is missing so if the tv is completely dead then you have a defective main board , the power board should be fine although you could still test those 4 fuses on the cold side of it , those are F9A03,04,05 and 06 but I doubt those are the problem , again that 5 volts would be on the main board namely those regulators mounted on it and as far as I can tell brings back that 5 volts to the inverter via the power board when the tv is on , something to test perhaps .

Shopjimmy has that main for $49 ; http://www.shopjimmy.com/mitsubishi-921c549005-digital-main-dm-board-for-lt-46244.htm

Dont forget to rate if that answers your question but then again you know how this works

Customer: replied 5 months ago.

Jack; Got a problem. Received board from shopjimmy,installed it. Got a red power light and a click when plugged in. Pressed power button got nothing. Held power button down for five or so seconds, released waited a few seconds got a series of fast green lights then back to steady red. Also, there are three plugs located in the center of TV that seem to have no place to go. I don't remember unplugging them. Maybe a picture?

Expert:  Jack replied 5 months ago.

???

Expert:  Master Fix It replied 5 months ago.

Hi Im am tech Michael.

It sounds like you may have received a bad board. You wouldn't believe how often that happens to even me a feild tech.

The very first thing to do is contact shopjimmy and exchange that board.

Once you have the new board, make sure you remove this board with caution for static ESD i will help you its also very possible you may have damaged this board by removing it from its packaging and releasing electrostatic discharge to the board. Static electricity is a big problem with these boards. But it may have just come to you damaged anyway lol.

Just return it for an exchange because it sounds as if the new board is working partially but not fully.

In any case, I will stick with you until this is complete.

Please rate my service kindly.

Also it is the only way I am credited for my time and expertise with you.

Once you rate, I will be notified and will add your question to my priority list so you can reach me anytime until this problem is solved.

Then you can reach me by simply replying to this message anytime.

Thank you

Sincerely

Tech Michael

Customer: replied 5 months ago.

Thanks Michael. I will re order and keep you informed.