How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mike G. Your Own Question
Mike G.
Mike G., Technician
Category: TV
Satisfied Customers: 5974
Experience:  10 Years Audio Video Repair & Setup
Type Your TV Question Here...
Mike G. is online now
A new question is answered every 9 seconds

TV is a 65" Vizio XVT Theater 3D model XVT3D650SV. It gets

Customer Question

TV is a 65" Vizio XVT Theater 3D model XVT3D650SV. It gets its signal from an Xfinity X1 box. A guy was working on a light switch, shorted to the switch box and then he turned off the circuit breaker. Kids were watching TV at the time and obviously it was lights out when at least the circuit breaker was flipped. Now the TV constantly shows "No Signal". Comcast says it is being sent a signal and came out and tested. I have switched the HDMI plugs on the back of the set and selected all the different inputs. Still"no signal." TV is on. Box is on. Seems like there must be a switch setting that needs to be turned on. Ideas?
Submitted: 4 months ago.
Category: TV
Expert:  Mike G. replied 4 months ago.

Welcome Todd. I am an experienced electronics field technician and your satisfaction is my top priority. We are now connected together on this convenient website. To get started, I need to know you are able to reply to me here...

As a TEST, do you have another tv in the house that you can plug this Comcast box into?

As a TEST, do you have something else like a bluray player that you can plug into this tv?


** My replies can take up to 5 minutes to appear **

** Do NOT start a new question **

Expert:  Mike G. replied 4 months ago.

Since I have not received any reply, I will go with the information given...

If you have verified that none of the hdmi ports work using known good hdmi cable and device (cable box/bluray player), then you are looking at a damaged Main board inside the tv. You could try a Factory Reset in the HELP/SUPPORT menu using the Vizio remote but doing a reset cannot overcome hardware failure. The board will have to be replaced, costs $150-$200, and may be hard to find in stock. If you want to DIY let me know so I can help you further.

If you are unable or unwilling to perform any of these procedures then a repair shop should be consulted. A shop charges $125 to come diagnose the problem and hand you an estimate for exactly what I just told you. Then at least another $175 in parts and labor. So the total can be $300 (or more).

I'm sorry for the bad news. Remember that I am here to help you. Please reply back if you need clarification on any of the above.

Before you go please take a moment to submit at least a 3 star rating at the top of this page. Then if you still need help you can reply back and I will be happy to assist you further.


Expert:  Mike G. replied 4 months ago.

Todd, just checking back in to see if you still need help, or perhaps you would like to acknowledge that my time and input has been helpful?

Related TV Questions