How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Shahid Your Own Question
Shahid
Shahid, Technician
Category: TV
Satisfied Customers: 9465
Experience:  I have been repairing electronic gear since 1993 as a qualified Sony tech
33243543
Type Your TV Question Here...
Shahid is online now
A new question is answered every 9 seconds

I have a sony bravia KDL-70R550A. I am having display issues

Customer Question

I have a sony bravia KDL-70R550A. I am having display issues in which I turn on the TV and it shows the Sony logo, then goes blank. Sometimes the power led will flash 5x at me. I have switched out the power supply, TCON board, and main board and still have the same problem. I noticed that if i unhook the left ribbon cable on the tcon board, and turn on my tv, the left side of the screen shows up and I can see menus and everything. As soon as I hook in this left ribbon cable, it goes back to being dark. Was the TCON board i purchased faulty or is it a problem withe the panel unit?
Submitted: 7 months ago.
Category: TV
Expert:  Shahid replied 7 months ago.
Hello and Welcome. My name is ***** ***** I'll assist you today. I'm sorry you're having trouble with it. I need additional info to troubleshoot the issue.- Do you still have old boards and can you please get the old symptoms back in TV?Thanks.
Customer: replied 7 months ago.
I do still have the boards yes. What do you mean the old symptoms?
Customer: replied 7 months ago.
The boards are in the TV right now
Expert:  Shahid replied 7 months ago.
I mean does the TV still display Sony logo screen with new boards or just gives 5 blinks power light error code?
Customer: replied 7 months ago.
it displays the sony logo, then goes black. no more 5 blinks.
Expert:  Shahid replied 7 months ago.
OK, one more question, did you buy this TV from Japan or from USA or any other country?
Customer: replied 7 months ago.
United states.
Expert:  Shahid replied 7 months ago.
OK, does TV power stay On or it switches Off after some time?Have you tried to upgrade TV firmware?
Customer: replied 7 months ago.
I have tried upgrading the firmware (when i unplug the left tcon ribbon cable I can see the left side of the screen). the screen said that it has the latest version installed already. TV power stays on, back light is on and all. I can hear the speaker volume when i remove the left cable of the TCON board.
Expert:  Shahid replied 7 months ago.
I understand, what new board is installed right now in TV?All three boards (mentioned in question post) or is it Main board and T-Con board and Power board?
Customer: replied 7 months ago.
All the main 3 boards are installed (TCON, Power, Mainboard)
Expert:  Shahid replied 7 months ago.
Thanks for the info, it still seems firmware issue and I would recommend to upgrade it by using USB memory stick, please go to following Sony link, download the firmware upgrade file, unzip it and copy the file as per instructions mentioned on Sony page, plug the USB stick in TV, replug TV power cord in and turn On the power. https://esupport.sony.com/US/p/swu-download.pl?mdl=KDL70R550A&upd_id=9861&os_group_id=18Upgrade process will start automatically, give it 15-20 minutes to finish, during the update the PIC OFF/TIMER indicator slowly blinks amber and the STANDBY indicator is red, TV should turn On after finishing upgrade process.Please reply back with the result and if problem resolved then a positive rating to answer would be highly appreciated.
Customer: replied 7 months ago.
from what i can tell (i can only see half the screen because i had to unhook that right tcon cable), it says i have the most up to date firmware.
Expert:  Shahid replied 7 months ago.
I understand yet I would recommend to try it by using USB memory stick to see if it helps.
Expert:  Shahid replied 7 months ago.
Also, have you tried to restore TV to default settings?if not yet, please try it as per following procedure..1. Turn on the TV.2. Using the supplied remote, press and hold the UP arrow button.3. While holding down the UP arrow button press the POWER button on the TV itself.4. When the TV goes off, release the POWER button and the UP arrow button.5. The TV will turn on by itself then the initial setup screen will be displayed. Follow the on-screen prompts to finish the setup. Please reply back with the result and if problem resolved then a positive rating to answer would be highly appreciated.
Expert:  Shahid replied 7 months ago.
Hi there, I wanted to briefly follow up with you and see how the info worked, and see if that accomplished what you were looking to do!Please reply back here if there is additional questions.Thank you.