How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jack Your Own Question
Jack
Jack, Technician
Category: TV
Satisfied Customers: 8343
Experience:  40 years experience as audio,video repair and installation tech
39158752
Type Your TV Question Here...
Jack is online now
A new question is answered every 9 seconds

I have a Visio UN60EH6003FXZA that had a snap and turned

Customer Question

Hi, I have a Visio UN60EH6003FXZA that had a snap and turned off. I lost picture once and replaced the TCON board. This time I replaced all three boards and I still get no indicator light and no power on. I thought that the power supply might be bad and replaced it wiht another one and
still no luck. Any suggestions?
Submitted: 7 months ago.
Category: TV
Expert:  Jack replied 7 months ago.
Hi , I`m JackPerhaps I can help you with this problem , a few questions coming up and please note that it may take a few minutes between replies;What is the version number of this tv ?You will find this near the model number on the back cover
Customer: replied 7 months ago.
Ih02
Expert:  Jack replied 7 months ago.
Hello , just saw your reply , give me a few , wasn`t expecting you any longer
Expert:  Jack replied 7 months ago.
Did you get that kit , check this link ;http://www.shopjimmy.com/samsung-un60eh6003fxza-complete-tv-repair-kit-version-2.htmOr did you buy them separately ?So right now the tv is basically dead , is that what you are saying ?
Customer: replied 7 months ago.
Yup, dead right now. 2 kits from Jimmy so far and the third is on the way.
Expert:  Jack replied 7 months ago.
Do they do anything at all when you replace them and then fail or simly do not help ??
Customer: replied 7 months ago.
I get nothing. Even swapping then around gets me nothing. My original pws got me at least a standby light but even if I go back to the original parts, nothing.
Expert:  Jack replied 7 months ago.
Not sure what to tell you on this then but i`d be curious to know what shopjimmy has to say , i mean you are effectively replacing the working guts of the tv !
Expert:  Jack replied 7 months ago.
Right now all I can suggest if you have another kit on the way is wait till you get it and try it then just let me know and we`ll take it from there .
Customer: replied 7 months ago.
Sounds good
Expert:  Jack replied 7 months ago.
o.k then , good luck
Customer: replied 7 months ago.
Hi jack, I just recieved my me kit from Jimmy. I put the power supply in and connected the wires and again nothing. I disconnected the wire on the top of the power board that goes to the lcd panel direct and I get a standby light and sound. When I reconnected the lcd lead it sparked. I checked the wires and see no sign of wear. It must be in the lcd panel connection in side. Ideas
Expert:  Jack replied 7 months ago.
That plug goes to the T-CON board , if you did replace it then replace it again or this time disconnect the panel (top connector) and leave that board online , if the tv acts normally then your panel is shorted and by all indications after 3 kits I would not be surprised

Related TV Questions