How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Electronic Engineer
Category: TV
Satisfied Customers: 16498
Experience:  Over 16 years of experience installing and repairing electronics.
30970729
Type Your TV Question Here...
Pete is online now
A new question is answered every 9 seconds

My name is ***** *****, I have a Polaroid 373B. I just

Customer Question

Hi my name is ***** *****, I have a Polaroid 373B. I just replaced the main board and powered it up, I get audio but no video. What would be the problem here? What info do you need from me to troubleshoot this?
JA: Thanks. Can you give me any more details about your issue?
Customer: Sure I had replaced the power supply a few months ago and finally got a decent one working after troubleshooting it... After that I replaced the main board and now I get the light in front lighting up red then blue when I power up Unfortunately I'm only getting audio and novideo I've checked all the voltages on e power supply with my trusty multi-meter and they're all good
JA: OK got it. Last thing — TV Technicians generally expect a deposit of about $18 to help with your type of question (you only pay if satisfied). Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 11 months ago.
Category: TV
Expert:  Pete replied 11 months ago.

Hi there,

If all input types are affected in the same way then suspect a fault with the replacement main board.

Where did you obtain the main board from? Does it work in a different TV?

Expert:  Pete replied 11 months ago.

Hi Jose, just checking in on your question. How did things turn out for you?

Customer: replied 11 months ago.
I purchased it from a reputable dealer with whom I've dealt with before. Before the main board replacement nothing happened, I didn't even have any lights come on. After I replaced it I had sound and the led in from would go from red to blue when I pushed the "on" button. I have ordered a replacement t-con board to see of that fixes the problem since I'm getting sound and the back light comea on but no picture. Hopefully that fixes the problem.
Expert:  Pete replied 11 months ago.

Ok, do let me know if you need anything else.

Don't forget to rate my help, it is how the site rewards me for my time :)

Pete.