How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Anthony_Infotech Your Own Question
Anthony_Infotech
Anthony_Infotech, Technician
Category: TV
Satisfied Customers: 13734
Experience:  20+ years experience TV expert (field and bench) 9 approved qualifications in TV-ELECTRONICS
18621325
Type Your TV Question Here...
Anthony_Infotech is online now
A new question is answered every 9 seconds

I'm having issues with a Samsung DLP HTL5075sx tv, There is

Customer Question

Anthony I'm having issues with a Samsung DLP HTL5075sx tv, There is no blue flame in the arc gap, the ballast is getting the 324 vdc I have read through all your previous diagnosis of other tvs and it has come down to a frayed wire on a board connected the color wheel, the color wheel is spinning freely at one speed. I don't know I should replace DMD board or not?
Submitted: 9 months ago.
Category: TV
Expert:  Anthony_Infotech replied 9 months ago.

Hello

Welcome

The color wheel will spin upto 9000 rpm it must do this BEFORE the ballast can fire, so is the color wheel spinning up OK?

Anthony

Customer: replied 9 months ago.
Yea it's spinning pretty fast
Expert:  Anthony_Infotech replied 9 months ago.

OK so we have to assume then that the color wheel is good, is the set then shutting down to 3 blinking lights on the front of the set?you do need see/hear the ballast doing its work?if that is the case you will need to replace it, you can get a new ballast from www.partstore.com <<click

The ballast must fire as its the next in line for work once the color wheel spins up

Let me know if you need more help or have any more queries

Please consider rating the answer positively there will be a rating bar of stars usually at the top of the page with this post thank you, ***** ***** positively enables me to receive credit from the site thanks again, the session will remain open and stay open as long as you need it, if you have any concerns please just let me know and I will answer any queries you have

Many Thanks

Anthony

Customer: replied 9 months ago.
I do hear the ballast coming on but I do not see the blue flame, now with the safety switch being tripped, there is only one light blinking in the front and it's the lamp light but when the safety switch is not tripped the standby blinks red and the lamp light blinks green
Expert:  Anthony_Infotech replied 9 months ago.

You should hear a fizz/click from the ballast (you must have the safety switch closed) its a distinctive click if the lamp does not get hit by the ballast all 3 lights will blink

Please remember also that the lamp door switch must be defeated as well as any rear safety switch, this is the blue one it should be in the down position

Anthony

Customer: replied 9 months ago.
I'm sorry I was referring to the lamp door switch when I said safety switch
Customer: replied 9 months ago.
But yes I do hear a click from the ballast but no blue flame in the arc gap
Expert:  Anthony_Infotech replied 9 months ago.

You will have to replace the ballast, you have done all that is necessary as regards ***** ***** nothing visual like bad capacitors on the board is obvious then the board will need to be replaced, you are left with 2 things ballast or lamp, the way it is it would appear the ballast is bad, just to emphasize you should be getting 3 blinking lights please check that lights carefully all 3 should be blinking as the lamp is not working because of

That is standby/temp>>>timer>>>lamp

Expert:  Anthony_Infotech replied 9 months ago.

Please consider rating the answer positively there will be a rating bar of stars usually at the top of the page with this post thank you, ***** ***** positively enables me to receive credit from the site thanks again, the session will remain open and stay open as long as you need it, if you have any concerns please just let me know and I will answer any queries you have

Many Thanks

Anthony

Customer: replied 9 months ago.
I have replaced my ballast and still getting no blue flame attempting to light the lamp
Customer: replied 9 months ago.
Is it possible the frayed wiring coming from the board on the color wheel is not sending the signal to light the lamp?
Expert:  Anthony_Infotech replied 9 months ago.

I am not sure what you mean by "frayed wire" there are ribbon leds not wires?can you take a photo of what you mean and upload here?use the paperclip

Anthony

Customer: replied 9 months ago.
The wire to the far right has been melted a tad
Expert:  Anthony_Infotech replied 9 months ago.

I cant see anything wrong here

Customer: replied 9 months ago.
Are you able to zoom in and identify the exposed wire?
Expert:  Anthony_Infotech replied 9 months ago.

Yes what color is it I simply cant see any frayed wire

Customer: replied 9 months ago.
White, farthest right on the circuit board on the end of the pin connector, the wire does not have any protective covering and looks like it is has melted a bit
Expert:  Anthony_Infotech replied 9 months ago.

you mean on that plug in the center of the pic NOT far right of pic?

Customer: replied 9 months ago.
the white wire on the right of the plug
Expert:  Anthony_Infotech replied 9 months ago.

No its not that sorry

Customer: replied 9 months ago.
I'm looking at a DMD board issue yes?
Expert:  Anthony_Infotech replied 9 months ago.

Yes but you are hearing the ballast??although not seeing it fire

What concerns me is your statement about the color wheel?its spinning freely at one speed?what do you mean by that?it should be spinning atb 9000RPM

Customer: replied 9 months ago.
I can hear the ballast clicking but no blue flame in the arc gap
Customer: replied 9 months ago.
It's spinning at a really fast speed so I'm assuming it's spinning at 9000 rpm
Expert:  Anthony_Infotech replied 9 months ago.

There should be a 5vdc supply on the plug from the DMD board let me know if you read that

You see if the ballast is not working you should not hear anything

Customer: replied 9 months ago.
Ok testing the voltage on ballast from the DMD board for some odd reason the blue flame decided to finally come on!
Expert:  Anthony_Infotech replied 9 months ago.

Is the lamp now lit set running?

Customer: replied 9 months ago.
In order for the ballast to light the lamp i have to touch the connectors with my multimeter pins but the lamp does not stay on it blinks for a couple of seconds and goes out
Expert:  Anthony_Infotech replied 9 months ago.

Yes that is odd it would seem like the DMD board has a problem then the thing is finding a DMD board for one of these is like trying to find the holy grail....

Expert:  Anthony_Infotech replied 9 months ago.

The meter is presenting an impedance leak so the fault is clearing or changing

Customer: replied 9 months ago.
I just tested my old ballast using the same method with the multimeter my ballast was never bad
Customer: replied 9 months ago.
I have found 2 different replacements, one on Amazon and one on eBay
Customer: replied 9 months ago.
The Amazon looks like this
Customer: replied 9 months ago.
Amazon
Customer: replied 9 months ago.
the eBay one looks like this
Customer: replied 9 months ago.
I'm not sure which one I'm going to need because I have the extra stuff already on my old DMD board that the Amazon board does not have
Expert:  Anthony_Infotech replied 9 months ago.

You need to get the partnumber from the board itself it will be on a sticky label or etched on the board

Anthony

Customer: replied 9 months ago.
That is the correct part, I have already recovered the part number from the board but what I'm wondering is whether or not I can get the board without the dlp chip since I already have one attached to the faulty board I have now
Expert:  Anthony_Infotech replied 9 months ago.

Yes usually they do come without the chip so if you are seeing them with the chip that is the opposite when I was ordering this board many years ago, they are pulled boards not new

Customer: replied 9 months ago.
should I get the one with a chip or without to save money!
Customer: replied 9 months ago.
Expert:  Anthony_Infotech replied 9 months ago.

I would get one with but let me know the price of with and without, I cant see the chip causing this however

Anthony

Expert:  Anthony_Infotech replied 9 months ago.

Its just to cover all bases

Customer: replied 9 months ago.
The one without is $20
Expert:  Anthony_Infotech replied 9 months ago.

Lol hardly going to break the bank how much is one with?

Customer: replied 9 months ago.
80
Expert:  Anthony_Infotech replied 9 months ago.

Its your call but I would get one with