How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Anthony_Infotech Your Own Question
Anthony_Infotech
Anthony_Infotech, Technician
Category: TV
Satisfied Customers: 13947
Experience:  20+ years experience TV expert (field and bench) 9 approved qualifications in TV-ELECTRONICS
18621325
Type Your TV Question Here...
Anthony_Infotech is online now
A new question is answered every 9 seconds

I have a Vizio e550i-b2. Have backlights but no picture.

Customer Question

I have a Vizio e550i-b2. Have backlights but no picture. Replaced main board, power board led driver board, and t-con board. Screen just varies blacks when I press input or menu
Submitted: 1 year ago.
Category: TV
Expert:  Anthony_Infotech replied 1 year ago.

Hello

Welcome

Is it exactly the same issue as before you replaced the boards?

Anthony

Customer: replied 1 year ago.
No. It would power up and turn off. Replaced main and it stayed on? I don't remember. I did main first, then power, then driver, t-con
Expert:  Anthony_Infotech replied 1 year ago.

Sorry you will have to get back to square one by putting the old boards back in and letting me know the fault you have then, there are reasons for this but you just need to do that first and we will move on a step at a time sorry for the hassle

Anthony

Expert:  Anthony_Infotech replied 1 year ago.

Put ALL the original boards back in again

Customer: replied 1 year ago.
All original in. Plugged in, power light came on and faded out in 2 seconds. No backlight
Customer: replied 1 year ago.
Scratch that, backlight is on but very dim
Customer: replied 1 year ago.
It seems like each time I push the power button the backlight jumps to the right brightness then fades quickly. They don't seem to go completely off regardless of pushing power
Expert:  Anthony_Infotech replied 1 year ago.

So you are saying you have backlight lit but NO powerlight that has gone out?are you sure

Anthony

Customer: replied 1 year ago.
The standby light doesn't come on unless I unplug it. Plug it in and standby lights up, fades out. Without unplugging, I press power and it lights and fades. Along w the backlight. But backlight stays on very dim. I press power again, and no standby light but the backlight goes to the right brightness and quickly fades but never goes completely out
Customer: replied 1 year ago.
The standby light turns on with plugging it in and fades, and is good for one power button push and fades but then it will not light again unless I unplug it
Expert:  Anthony_Infotech replied 1 year ago.

OK I understand so this would have been you ORIGINAL problem, now the mainboard you ordered and the original board do they both have EXACTLY the same part-number found on the board itself on a sticky label or etched on the board?

Customer: replied 1 year ago.
34,76N02,XXX R01 CRF
Expert:  Anthony_Infotech replied 1 year ago.

55.76Q01.001G

The number will look similar to the one above for both boards, the number you sent is NOT the partnumber

Expert:  Anthony_Infotech replied 1 year ago.

Or is both boards 34.76NO2 XXX

Expert:  Anthony_Infotech replied 1 year ago.

OK that could be the partnumber but let me know if both are the same number and let me know where you got the boards from please

Anthony

Customer: replied 1 year ago.
Gotcha. That was number on big metal plate in center. Replacement says 5576Q01001G418B96F5J21E. Original is 5576Q01001G348A386FJ21B
Expert:  Anthony_Infotech replied 1 year ago.

They look like they are both the same however I would send that main-board back as faulty, its not unusual that 1 in every 5 boards is usually bad because they are pulled from scrap sets and move on from that.

Its my belief the replacement main is bad

Let me know how it works out

Anthony

Customer: replied 1 year ago.
Ok, got another main board, installed it, and I'm back to original problem
Expert:  Anthony_Infotech replied 1 year ago.

Connect up a DVD player continually press the INPUT button of the TV remote do you get the sound through?

Customer: replied 1 year ago.
Sound comes thru
Expert:  Anthony_Infotech replied 1 year ago.

I am sorry we have got around to verifying the LCD panel as being bad (assuming you replaced the t-con) it is not an option to replace the panel I am sorry for this dismal news.

The boards you can probably send back

Let me know if you need more info

Anthony

Customer: replied 1 year ago.
Could it be the ribbon cable? I've heard it doesn't take much to tweak them?
Expert:  Anthony_Infotech replied 1 year ago.

No its not the LVDS lead (lead from main to t-con) its the panel itself

Sorry for this the only anomaly is I have no idea why the main-board is bad or went bad that bit does not make sense at all

Please consider rating the answer positively thank you there will be a rating band with this post, rating me positively enables me to receive credit from the site, thank you, ***** ***** will remain open and stay open as long as you need it, if you have any concerns please just let me know and I will answer any queries you have