How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Shahid Your Own Question
Shahid
Shahid, Technician
Category: TV
Satisfied Customers: 9465
Experience:  I have been repairing electronic gear since 1993 as a qualified Sony tech
33243543
Type Your TV Question Here...
Shahid is online now
A new question is answered every 9 seconds

I have a tc-p50u50, 3 years old. Worked fine until I took it

Customer Question

I have a tc-p50u50, 3 years old. Worked fine until I took it off the wall mount for work on wall. After work complete, plugged in unit and got 7 blink code. Always use a surge protector.
Submitted: 1 year ago.
Category: TV
Expert:  Shahid replied 1 year ago.

Hello, I'm Shahid and will be happy to assist you.

- Do you have multimeter and can check volts on circuit boards inside TV to troubleshoot the issue?

- Was TV dropped or screen hit by any hard thing while taking it off of wall mount or placing it some where?

These info will help to assist you further.

Thanks.

Customer: replied 1 year ago.
Was not dropped or hit, I do have a multimeter and can check circuit boards inside the TV
Expert:  Shahid replied 1 year ago.

OK, please unplug the TV and remove connector SS11 from the SS board. Plug-in the TV and turn it on.

Is the power LED blinking 7 or 8 times now?

Customer: replied 1 year ago.
No change, still 7 blinks.
Expert:  Shahid replied 1 year ago.

OK, unplug the TV and reconnect SS11. Remove SC20 from the SC board. Plug-in the TV and turn it on.

Is the power LED blinking 7 or 8 times?

Customer: replied 1 year ago.
With SC20 removed from the SC board it blinks 8 times when you turn on the power.
Expert:  Shahid replied 1 year ago.

Thanks for the info. There are two boards located on left side of SC board calls SU and SD boards and one of them isn't working and causing the problem, please replug connectors between SC and SU/SD boards and again check, if problem persist then replace SU and SD boards that will help to resolve the problem. Please check following board supplier link to get required board..

http://www.shopjimmy.com/catalogsearch/result/?q=tc-p50u50

I trust my input will help you out. Please feel free to respond if you have any additional questions.
A positive rating to answer would be greatly appreciated, please click on 5 star on this page then click submit/finish button so I can get credit on website for my work.
Regards,
Shahid.

Customer: replied 1 year ago.
Replaced both boards, now I get a buzzing noise from the power board and the the 7 blink code.
Expert:  Shahid replied 1 year ago.

This is odd, did you get identical boards as replacement?