How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Louie Your Own Question
Louie
Louie, Technician
Category: TV
Satisfied Customers: 11648
Experience:  25+ yrs. experience in the field and 5+ yrs. online, down to component level.
13948492
Type Your TV Question Here...
Louie is online now
A new question is answered every 9 seconds

I have the exact problem currently defined on your website

Customer Question

Hi I have the exact problem currently defined on your website for a sylvania lc320sl1...and i just installed a brand new power supply board....the power now comes on...yther green lite blinks several times and then it goes to red stanby and wont shut off....i kept tying for many times always the same cycle???
Jack chearmonte
Submitted: 1 year ago.
Category: TV
Expert:  Louie replied 1 year ago.

Hi Jack and welcome to JustAnswer,

Thank you for the question and your patience. Should you still need assistance for information purposes only...

Initially, it would appear to be a multiple fault issue where the power supply board is 1 and another now that causes the unit to kick in auto-protect mode.

Are you able to check which output voltage of the power supply is not present when the "...green lite blinks..." ?