How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask TV Tech1 Your Own Question
TV Tech1
TV Tech1, Technician
Category: TV
Satisfied Customers: 5312
Experience:  30 Years experience. Authorized Warranty servicer.
26807325
Type Your TV Question Here...
TV Tech1 is online now
A new question is answered every 9 seconds

Just replaced the dcp chip....no pic..no sound..status light

Customer Question

Just replaced the dcp chip....no pic..no sound..status light is on red
Submitted: 1 year ago.
Category: TV
Customer: replied 1 year ago.
I am fearful that I have connected the cables incorrectly ...the small ones inside the tv with the clips
Customer: replied 1 year ago.
I had no picture but sound...replaced the bulb...got a beautiful picture...Then a few weeks later...started getting small white and black dots. So I sent away for chip....replaced the chip....but no pic no sound....status light is solid red
I think my small cables are hooked up incorrectly
Expert:  Aric replied 1 year ago.

Hello, What is the model number off of the back of the Mitsubishi?

Also, please elaborate as to why you think the small cable with clips is connected incorrectly.

Customer: replied 1 year ago.
Model # *****I think they are connected incorrectly because I have one that I can't find were it goes(plugs into)
Expert:  Aric replied 1 year ago.

Okay you're going to need to take a picture of the Formatter board (where the chip installs), and show me that cable as well. Your red status light is on because there's no communication from the Formatter to the Light Engine.

Customer: replied 1 year ago.
Please help me.....I have to get this to work......and I'm not paying another dime to talk on the phone....I already paid $28 I'm hoping you can help
Expert:  Aric replied 1 year ago.

I'm not asking you to talk on the phone- the site is sending that. Talking on the phone isn't going to help us- but a picture is needed. You left something disconnect and now have no communication from the formatter to the engine. Read my reply above please.

Customer: replied 1 year ago.
I'm sorry
I will take a picture....but I need to take things apart s ill need a few minutes
Expert:  Aric replied 1 year ago.

No problem, and no hurry. Troubleshooting things takes as long as it takes. Simply reply back when able and I will take a look and see what's what.

Customer: replied 1 year ago.
Hi Aric,
How do I get these pics to you....do you have an email address I can send them to
Expert:  Aric replied 1 year ago.
You would upload them to your PC, then click the paperclip icon on your page and add files.
Customer: replied 1 year ago.
I hope one of those pics shows the wire that has no place to be plugged in. I was going to undo everything and try to start over with your assistance possibly...LOL..I JUST HAVE TO GET THIS UP AND RUNNING OR ILL JUST DIE.I WOULD HAVE WATCHED IT WITH THE DOTS IF I THOUGHT I COULDNT HANDLE THIS TASK....BUT I REALLY THOUGHT I WOULD
Expert:  Aric replied 1 year ago.

I need to see a picture of the entire back of the TV's insides, and also a picture of the board where you replaced the chip.

Customer: replied 1 year ago.
Oh no
That means taking everything apart again....oh boy...ok
Expert:  Aric replied 1 year ago.

Why are you putting everything back together if the TV is not working?

Expert:  Aric replied 1 year ago.

I'm sorry, but I will need to opt out- which simply opens the question for other Experts to assist. Please do not rate at this point, as it may hinder another from participating in this dialog. If you're not interested in any further assistance with this problem, you can self-refund by simply checking the HELP link below, or contacting Customer Service from the Home Page.
http://ww2.justanswer.com/help/topics/142

Customer: replied 1 year ago.
I don't understand why your opting out....I just did what you asked and have the pictures you are requesting. I do hope someone will be back sooner than later....I really want to resolve this I hope that whom ever helps me will have some patience and a little more understanding..I'm a 52 year old woman trying to fix her TV that's all. Gentlemen...Thank You
Expert:  TV Tech1 replied 1 year ago.

I'm pretty sure this will fix it.

Expert:  TV Tech1 replied 1 year ago.

Make sure the flip -tab points UP on that connector, and the FOILS on that ribbon cable point UP too when inserted.

Expert:  TV Tech1 replied 1 year ago.

Hello, have you seen the picture I posted back to you??