How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Anthony_Infotech Your Own Question
Anthony_Infotech
Anthony_Infotech, Technician
Category: TV
Satisfied Customers: 14087
Experience:  20+ years experience TV expert (field and bench) 9 approved qualifications in TV-ELECTRONICS
18621325
Type Your TV Question Here...
Anthony_Infotech is online now
A new question is answered every 9 seconds

Im having issues with a Mitsubishi WD-60737 DLP tv that

Customer Question

Hi, Im having issues with a Mitsubishi WD-60737 DLP tv that wont turn on. I bought a good high dollar Osram,Mitsu Bulb that clearly needed to be replaced... make a long story short since i have replaced the lamp ballast, power board, main board (the last three were used...so yeah no telling) but still will not turn on. Upon pushing the power button the green light flashes for a few times, then the amber for a few times...then nothing. Error code i keep getting is 1-2...so now im stumped. Scott
Submitted: 1 year ago.
Category: TV
Expert:  Anthony_Infotech replied 1 year ago.
Hello my name is***** did you get the lamp from please and for what price? Anthony
Customer: replied 1 year ago.
I got it from Shop Jimmy.com ...tv part supply place online and it was a Mitsubishi 915B403001 DLP Replacement Lamp with Philips Bulb, It came with the housing and all.
Expert:  Anthony_Infotech replied 1 year ago.
Hello I am not sure if you are aware that their are copy lamps that simply wont work particularly in a set like this it has to be genuine OEM pref got from mitsubishi themselves here https://mitsuparts.3diamonds.com/ We have endless trouble with copy lamps and its my belief you may have been sold a copy lamp that wont work from the go Let me know your thoughts here Anthony Anthony
Customer: replied 1 year ago.
Anthony, yeah you maybe right for sure, I spent $99 on the damn thing but that doesnt mean anything, is there a way to test to see if i have voltage getting to the lamp and if so what should it be, i have a decent mutimeter...if that helps. Scott
Expert:  Anthony_Infotech replied 1 year ago.
No you can't check an arc lamp at all you can only replace it to eliminate, hopefully you are activating the error report when the set has shut down if you do it any other time you only get the 1/2 code. Anthony
Customer: replied 1 year ago.
Ok I understand I cant check the lamp itself, but can i check voltage to the lamp somehow...or at least to the lamp ballast?
Customer: replied 1 year ago.
And yes im kind of baffled why i keep getting the 1/2 code because im not unplugging the set also i have checked it like 6 times, still same code
Expert:  Anthony_Infotech replied 1 year ago.
Yes you can do that you should have around 340vdc or near coming into the ballast from the powerboard it means measuring across a single plug on the ballast, but its not likely to be that but check anyhow, you should be able to hear the ballast trying to fire the lamp or see a flash from it
Expert:  Anthony_Infotech replied 1 year ago.
You see if their was a problem with the ballast it will be reported by the error reporting software
Customer: replied 1 year ago.
Anthony, also when i first push the power button the green light flashes twice very fast then the amber 5 times slowly...then i hear a click... click-click right at the main/power board area....and then nothing ...does that help ??
Expert:  Anthony_Infotech replied 1 year ago.
The click is likely the ballast trying to fire the lamp?that will make a click as it trys to get the lamp going
Customer: replied 1 year ago.
Ok, thats the thing, i dont hear or see anything at the ballast, and ive switched it back and forth between the original and the used ballast i bought online.,,,??
Customer: replied 1 year ago.
Ok, well ill check the voltage to the ballast next...also its way on the other side of the set removed from the main and power board where im hearing the clicks...does that make sense?
Expert:  Anthony_Infotech replied 1 year ago.
Have you tried the error report again?when the set shuts down to the fault then activate it
Expert:  Anthony_Infotech replied 1 year ago.
It should be reported by the error report software at the moment that 1/2 means no error
Customer: replied 1 year ago.
Im going to check the error report, But the thing is, i have no clue if its on or shut down because im getting nothing except the clicks and of course the green then ***** *****ght...see what i mean?
Customer: replied 1 year ago.
Everytime i push the power button i get the same thing....green light flashes, then the amber...then 3 clicks...and nothing else
Expert:  Anthony_Infotech replied 1 year ago.
what is the ***** *****ght you are seeing blinking?it will be labelled on the set
Expert:  Anthony_Infotech replied 1 year ago.
is it the status light and is it blinking slow?
Customer: replied 1 year ago.
Its labeled "status", so yeah it blinks 2 green then 5 amber, or yellow....then the clicks
Expert:  Anthony_Infotech replied 1 year ago.
yellow slow
Customer: replied 1 year ago.
2 rapid green followed by 5 slow yellow
Expert:  Anthony_Infotech replied 1 year ago.
Thats the lamp cover open?you must put the lamp cover on for the set to start
Expert:  Anthony_Infotech replied 1 year ago.
Have you done that?
Customer: replied 1 year ago.
i have had it on ....right now its off but i have the switch held by a sharpie to make sure its in the correct position, but either with the door on or off with the pen its the same both ways...so i would have to say for sure the switch is help properly...true?
Expert:  Anthony_Infotech replied 1 year ago.
Yes but that's what a slow blinking status light means, unless you have a problem with the switch also the error report should be 3/2 so maybe not, have you put the old mainboard back in?that's what I would do next
Customer: replied 1 year ago.
I have not put the old mainboard back in...so far ive checked checked and re-checked connections and obvious stuff. Also put the old ballast back in, same stuff, then put the old power board back, same stuff...ill do the main next and see whats up....rrrrr
Expert:  Anthony_Infotech replied 1 year ago.
That is the ORIGINAL mainboard its unlikely to be faulty
Expert:  Anthony_Infotech replied 1 year ago.
The thing is a slow blinking status light is a problem with the lamp cover thats what it is reporting so yes put the mainboard back
Customer: replied 1 year ago.
OK, does it matter it only blinks yellow slowly 5 times? ...or should it keep on flashing? Is there a way to check the switch ?
Expert:  Anthony_Infotech replied 1 year ago.
I am not sure on that, you would need to get the switch out or locate the leads from it to measure continuity......let me know what happens when you put main back
Customer: replied 1 year ago.
Im on it, this tv is going to get fixed if it kills me.... and it just might!! lol
Customer: replied 1 year ago.
I know just enough about electronics etc to be dangerous...im a collision bodyman by trade
Expert:  Anthony_Infotech replied 1 year ago.
Lol And I can can just about prep fill and paint a small dent on my car that I only just get away with!