How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Anthony_Infotech Your Own Question
Anthony_Infotech
Anthony_Infotech, Technician
Category: TV
Satisfied Customers: 13717
Experience:  20+ years experience TV expert (field and bench) 9 approved qualifications in TV-ELECTRONICS
18621325
Type Your TV Question Here...
Anthony_Infotech is online now
A new question is answered every 9 seconds

I have an lg50pc3d television. The screen started flashing.

Customer Question

I have an lg50pc3d television. The screen started flashing. The y board is ticking about 1 per second even with the buffers connected.
Should I just replace the y board? Or should I replace the buffers as well.
Submitted: 1 year ago.
Category: TV
Expert:  Anthony_Infotech replied 1 year ago.
Hello my name is Anthony
Welcome
Thanks for the Question

Have you measured the voltages for the Vs and Va on the powerboard?that has to be the first check ,you can't judge anything by any noises

Let me know

Anthony
Customer: replied 1 year ago.
Ok. I have to head to work. I will measure once I get back home and let you know.
Expert:  Anthony_Infotech replied 1 year ago.
OK yes thats the first procedural check

Anthony
Customer: replied 1 year ago.
the voltages are 197.1 and 61 volts
Expert:  Anthony_Infotech replied 1 year ago.
OK that seems about correct for the Vs and Va so their is no short circuit on the scan boards the power board is working, look at the logic board that is the little board with many leads feeding the scan boards is the led lit or blinking?
Expert:  Anthony_Infotech replied 1 year ago.
that is the led on the logic board itself this gives some ref as if the logic board is working
Customer: replied 1 year ago.
one blinks as if communicating - 3 are on solid
Expert:  Anthony_Infotech replied 1 year ago.
That would sound like its working, have you double checked all ribbon leads are home and good taken out checked then re-inserted?the way it is the scan boards have no short (they usually go short when bad)the powerboard and logic are seemingly at this point working, it could still be scan board and buffer issues but then your left with a board swapping exercise Let me know if ribbon leads are good
Customer: replied 1 year ago.
yes I took out the ribbon cables and re-inserted it :-)
Expert:  Anthony_Infotech replied 1 year ago.
I'm afraid your in a situation of swapping boards now it could be the Y buffer like you said and it may not have damaged the Y scan (yet) so try the buffer first as the Y scan seems to be OK its the buffer that damages the Y scan usually and if it was short I would be asking you to replace both, just to add you do need to be careful injecting money into a set of this age Let me know if you need more info A positive rating is appreciated thank you, ***** ***** be a rating bar with this post, thanks again, please note the question will not close RegardsAnthony
Expert:  Anthony_Infotech replied 1 year ago.
Maurice how is this working out please?

Anthony