How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Aric Your Own Question
Aric, Technician
Category: TV
Satisfied Customers: 41468
Experience:  15+ years in the field. Owner of AV Installation, OEM and Repair company
Type Your TV Question Here...
Aric is online now
A new question is answered every 9 seconds

I have a Hitachi LED LCD TV (LE47EC06AU) and last night it

This answer was rated:

I have a Hitachi LED LCD TV (LE47EC06AU) and last night it was working fine this morning every channel says no service and some channels even just a purple screen?
Hello and thank you for the question.

This can be due to one of two things. To tell you how to proceed, I need to know if you're using a cable box, or direct coaxial cable to the TV?

Also, which remote do you normally use to operate the TV- the Sharp remote, or a cable box remote?
Customer: replied 3 years ago.

We use the TV remote to operate the TV. I believe we are using a direct coaxial cable to the TV buty I'm not sure.

Thank you.

In order to tell you how to correct this problem, I need to know for sure if you can check the back of the TV and follow the cable to see if there's a cable box or not. The solution we use will depend on it.
Customer: replied 3 years ago.

There is no Cable box.

Okay, the No Service message does not sound right.

Do you mean a No Signal message?

Also, do you actually see the channel number on the screen, or just a No Signal message?

Do you have the original remote, and do you see a button labeled INPUT?
Customer: replied 3 years ago.

I just went to check and the TV is now working. Go figure.


Sorry the message was no signal though and yes the channel information was coming up.


There is an INPUT button on the remote.


If you could please let me know how to fix it if it happens again that would be great.

If this problem happens again, press the Input button and choose another Input, then switch it back to the TV Input. The micro-processor in the TV sometimes locks up and you need to change the Input to another one, then change it back.

If you need further assistance let me know and please do not forget to rate my service accordingly.
Aric and 3 other TV Specialists are ready to help you