How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Shahid Your Own Question
Shahid, Technician
Category: TV
Satisfied Customers: 9349
Experience:  I have been repairing electronic gear since 1993 as a qualified Sony tech
Type Your TV Question Here...
Shahid is online now
A new question is answered every 9 seconds

I have a Sony Bravia KDL 32L5000 that will only turn on after

This answer was rated:

I have a Sony Bravia KDL 32L5000 that will only turn on after several rounds of "unplugging, waiting a few minutes, then plugging back in. Is this a power board issue?
Hello, my name isXXXXX be happy to assist you,

Please allow me to ask you a few questions about your TV so that we can troubleshoot the issue.

- Does power indicator light blink when TV doesn't turn On?

Please provide me that info, it will help to answer the question.

Customer: replied 3 years ago.
No lights come on at all. Just clicks twice
Thanks Jamie for the reply.

- Do you have voltmeter and can check volts inside TV?

Customer: replied 3 years ago.
Not right now. I can get one tomorrow
Hi Jamie,

No problem, please check STBY 3.3V at output connector of power supply board, if that volts goes down or doesn't stay constant then replace power supply board that is available in, please check following link to view board price info..

This kind of problem can occur due to defective main board or back light inverter as well if power supply board swapping doesn't help.

I trust my input will help you out. Please feel free to respond if you have any additional questions.

A positive rating to answer would be greatly appreciated!

Shahid and other TV Specialists are ready to help you
Customer: replied 3 years ago.
Ended up replacing the main board last week, worked like new until today. It's back to not turning on. I know will replace the board since it is still under warrantee, but is there something else I should be checking? I should have been able to last longer an a week
Hi Jamie,

Sorry to hear that it is not working again.
I would check connectors that were removed during main board replacement to make sure all are tight and plugged securely.
Can you please do that and post back the results.