How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Louie Your Own Question
Louie
Louie, Technician
Category: TV
Satisfied Customers: 2557
Experience:  25+ yrs. experience in the field and 5+ yrs. online, down to component level.
13948492
Type Your TV Question Here...
Louie is online now
A new question is answered every 9 seconds

Hi: I got a HITACHI Plasma TV 42PD5000 for 6 years. Now,

Customer Question

Hi:
I got a HITACHI Plasma TV 42PD5000 for 6 years.
Now, its totally dead, no picture, no sound, no red nor green LED on.

Here are the findings & action taken:-
a. 3A mains fuse blown - replaced.
b. Resistor R004 & R005 10 ohm 5w open - replaced.
c. FET 2SK2843 shorted - replaced.

Results:-
1.Stby red LED on, use remote can turn the green LED on only, no picture.
2.Stby 5v & Stby 3.3v availiable,
3.No 5v, 12v, 30v found at CNPPS, nor VA & VS volt.
4.Relay RL001 & RL002 first energized, then de-energized.

Further measurement & action:-
a. Unplug CNPPS & CN69, direct linked Stby 5v to CNPPS pin 4,5 (5v).
Result:- same -Stby red LED on, use remote can turn the green LED on only, no picture.
Relay RL001 & RL002 first energized, then de-energized


I understand the protection circuit activaties the 2 relays which cut off the mains supply to switching circuit hence the whole TV stop working.
However, i couldn't locate further defects though i have checked for bulgeing caps, shorted diodes, shorted FETs, shorted photo couplers....

Kindly,if you could help me to explore further & solve the problem!
Thanks!!
Submitted: 3 years ago.
Category: TV
Expert:  Anthony_Infotech replied 3 years ago.
Hello
Welcome
Thanks for the Question

I may be a few minutes between each request for info thanks for your patience!

It sounds like one of the scan boards has gone bad, please unplug the X and Y sustain boards found both sides of the set and see if the Vs and Va come up

Let me know please

Anthony
Customer: replied 3 years ago.
Relist: Answer quality.
Not familar wth 42PD5000.
Cannot point out the defects.
Expert:  Dan replied 3 years ago.
Welcome! I'm Dan, a TV repair pro with more than 10 years of experience in consumer electronics troubleshooting and repair. I'd be happy to help!

Do you still need help on the Hitachi?



Dan
Customer: replied 3 years ago.

 


Yes,please read all my findings (as posted) on the faulty TV set & take a look at the sechmatic of 42PD 5000 before giving me the correct answer.


 


See if you can identify the faulty compoents.


Thanks


Fernado

Expert:  Dan replied 3 years ago.
Hi,

What are you getting on Vcc?



Dan
Customer: replied 3 years ago.


Hi Dan:


 


Vcc=0V.


They all merge from CNPPS (PIN 3,4,5)


 


Fernado


 


 

Expert:  Dan replied 3 years ago.
OK, let's disconnect the power cord and check the VS and VA lines for shorts to ground.



Dan
Customer: replied 3 years ago.


Hi Dan :


No shorts for Va &Vs>


Forward 7 ohms, reverse 1k ohms for Va &Vs.


 


Fernado.