How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask alr3d Your Own Question
alr3d
alr3d, Technician
Category: TV
Satisfied Customers: 766
Experience:  tv repair
6460921
Type Your TV Question Here...
alr3d is online now
A new question is answered every 9 seconds

hi, I have an lg pdp50x3 50" plasma that wont power up (switch

This answer was rated:

hi, I have an lg pdp50x3 50" plasma that wont power up (switch on), when i press the input button to switch it on you here the relay click and within a few seconds it goes back to standby. any help would be much appreciated, thanks, leyton.

this is a issue inside the tv. is this something you are fixing yourself? or do you need a cost on a repair?

 

 

 

Allan

Customer: replied 4 years ago.

THANKS FOR YOUR REPLY, YES IM GONNA HAVE A GO MYSELF.

ok pull the back off and take a picture with the back off the tv. then use the paper clip button above to attach the picture.

 

 

Allan

Customer: replied 4 years ago.
for some reason it wont upload my photos, sorry
are you getting a error?
Customer: replied 4 years ago.
no i get a couple of leds light up on one of the pcbs you here a quiet buzz from the ysus board the tv goes back to standby.

when you try to load the pictures... do you get a error?

 

 

Allan

Customer: replied 4 years ago.
no it doesnt get that far, so im getting no picture at all, it seems that its going to standby just before the picture comes on.
Customer: replied 4 years ago.
no problem, ive just sent them.
ok when they get them to me i will reply back to you.
Customer: replied 4 years ago.
ok
THANK YOU :)
Customer: replied 4 years ago.
ive just realised you were talking about the pictures not the tv picture, stupid me.

yes i need pictures of the tv with the back off.

 

Allan

Customer: replied 4 years ago.
its ok i sent them an hour ago, when you said is there an error message i thought you meant from the tv.

no problem

i will let you know when they send them to me.

 

 

Allan

ok got the pictures

1. check the fuses i have marked in the picture.

2. i marked a connector in blue. on the left of the connector on the board it tells you what each wire is. tell me what each one is.

 

graphic

Customer: replied 4 years ago.
ok, fuses are good, ive visually checked all capacitors and they look fine, the cable youve circled are as followed- from top to bottom on power board( v-s,v-s,v-s,nc,gnd,gnd,gnd,gnd,v-a,v-a) then on the YSUS board from top to bottom( +va,+va,gnd,gnd,gnd,gnd,nc,+vs,+vs,+vs).

ok tv unplugged

ohm VS and VA to ground. use the metal part of the panel as ground. tell me what the readings are.

 

Allan

Customer: replied 4 years ago.
va = .535 and vs = .477
is this ohms or meg ohms or k ohms?
Customer: replied 4 years ago.
2k

ok good

i now need a DC reading from the same two points with the tv on. you may have to turn it on several times to get these readings.

 

Allan

Customer: replied 4 years ago.
ok, i switch on the tv and theres about 3-4 seconds delay, then theres a quiet buzzing coming from ysus board then just after the buzzing I started to get to about 40v dc from vs and va then it just goes back to standby so its impossible to get an accurate reading.
ok unplug the connector are retest points on the board itself.
Customer: replied 4 years ago.
sorry when you say retest points what do you mean?
the DC voltages on vs and va. but you will test it on the pins this time because the connector will be unplugged.
Customer: replied 4 years ago.
ok will try it now.
ok
Customer: replied 4 years ago.
testing at power board, no voltage at vs and im getting 40vdc at va just before it shuts down.

ok plug back in connector. then unhook the connector in the new marked picture. then retest voltages on the same connector we have been working on.

also tell me a little about the noise you hear from the y-sus board.

 

 

graphic

Customer: replied 4 years ago.
im getting 0.7vdc from vs and 1.8vdc at va it then rises to about 40vdc as it shuts down. the noise is actually coming from the power board and its like a quiet whining sound.
yes i think we have a bad power board. the VS never comes up and should be over 100v dc.i would replace it
Customer: replied 4 years ago.
ok thanks for your patience and help andrew, im actually a gas engineer by trade so im used to fault finding on pcbs but when i opened the tv i almost fainted, anyway thanks again. by the way how do i pay?
i will send the accept button now
alr3d and 4 other TV Specialists are ready to help you