How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tim Nolan Your Own Question
Tim Nolan
Tim Nolan, TV Repair Technician
Category: TV
Satisfied Customers: 19454
Experience:  Factory trained TV repair technician. U.S. NAVY trained.
Type Your TV Question Here...
Tim Nolan is online now
A new question is answered every 9 seconds

I have a Swisstec tv and when I switch it on a picture comes

Customer Question

I have a Swisstec tv and when I switch it on a picture comes on for a second and then the screen goes black. The light on it stays green and there does not apperar to be an issue with the power supply. Is there an easy fix for this please?
Submitted: 5 years ago.
Category: TV
Expert:  Tim Nolan replied 5 years ago.
Thank you for posting your question on Just Answer! I will be happy to help you with this problem. Can you please give us some more information so I can better answer your questions.

-What is the model number for the television? (this can be found on the back of the unit)
-How old is the unit?
- Do you have this problem while watching all different devices hooked to this television? (DVD player, cable, satellite, game counsel, etc.)

Please give me this information and I will be happy to assist you further.

Thank you,
Tim Nolan
Customer: replied 5 years ago.
Hi Tim,
the model no is SWI-E16B07N01G-833
I think its about 1-2 years old
The problem exists no matter what is attached.

Expert:  Tim Nolan replied 5 years ago.
Does sound go out?

Customer: replied 5 years ago.
There does not appear to be any sound.
Expert:  Tim Nolan replied 5 years ago.
There are a couple of things that could cause this, unfortunately there is no reset for this television other than unplugging it. It will have an internal failure at this point. I will try to explain the possibilities the best I can. The problem here is that it is almost impossible to be repaired due to the cost...

First you could have a failure in the power supply, we have seen some capacitors fail in your model and cause funky problems like this. If this is the case you could be looking at somewhere around $175-$200 to fix the set.

Lastly you could have a problem with the panel itself, this would mean a new set for sure because the part cost is more than a new set. The panel in your tv is about $500 just for the part.

Any of these could cause your problem, but it will require troubleshooting to determine the exact cause of your problem. If you have experience, and test equipment and would like to attempt some troubleshooting I will be happy to assist you, however if you do not have equipment or experience then you would need a repairman at this time to get an exact diagnosis. I am sorry that I don't have a quick fix or easy answer for you on this one, it is definitely an internal failure.

If you would like any additional information or have more questions please don't hesitate to ask!

Please never accept an answer until you are 100% satisfied and feel you can leave positive feedback. If I have answered your questions and met your needs then please press the green "accept" button. Otherwise please feel free to ask anything else to get your problem resolved. Positive feedback is always appreciated!

Thank you,
Tim Nolan