How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Aric Your Own Question
Aric
Aric, Technician
Category: TV
Satisfied Customers: 42562
Experience:  15+ years in the field. Owner of AV Installation, OEM and Repair company
24739752
Type Your TV Question Here...
Aric is online now
A new question is answered every 9 seconds

I have a 60 in. wide screen mitsubishi tv. model #WD-60737.

Customer Question

I have a 60 in. wide screen mitsubishi tv. model #WD-60737. It has sound but no picture.
Looked in in back, there is no light. did here a popping sound and then a buzzing sound
before this happened. what would cause this and to fix it?
My email address is. [email protected]
Submitted: 5 years ago.
Category: TV
Expert:  Aric replied 5 years ago.

Hello, My name is Aric and I will be glad to assist you.

 

How long have you had the set for, and has any work ever been done to it?

 

Also, are there any blinking lights on the front of the TV?

Customer: replied 5 years ago.

2 years no work has ever been done to it

when i left the tv on andand only got sound after about a minute mayby less it shut off on its owne and a red light apears does not blink.

Expert:  Aric replied 5 years ago.

Try this with the TV OFF.

 

Press and hold the ACTIVITY and Channel DOWN on the front panel until the status light starts flashing. It will flash a two digit code: 3-4, 4-2, 6-6, etc.

Customer: replied 5 years ago.
code 1-2
Expert:  Aric replied 5 years ago.
The code 1-2 indicates no problems detected. Can you please try this several more times and let me know if you get any other code?
Customer: replied 5 years ago.
still gives the same code 1-2
Expert:  Aric replied 5 years ago.
Hmmm, that is bizarre. It sounds like the diagnostics are not picking up the problem. When you power up the set, listen carefully to the lower rear of the set. You should hear the fans kick in (whirr), then the color wheel (a louder whirrr), then lastly the ballast should click and buzz slightly. Do you hear all three of these things just no Lamp lighting?
Customer: replied 5 years ago.
I ONLY HERD 1 WHIRR THE LOUDER ONE. I DONT HERE NO BUZZ. I DO HERE A SMALL WHIRR. BUT NOW I DONT HAVE ANY SOUND. AND IT STILL GIVES ME THE SAME CODE. 1-2
Expert:  Aric replied 5 years ago.

Thanks for the reply.

 

The problem is that the Lamp needs to be replaced. The ballast is not even clicking on because the Lamp is open, and the unit sense No Lamp is installed. The average life for these lamps is between 2-4 years, but they can also need to be replaced sooner. Here is a link where you can purchase the Lamp for your set.

 

http://www.buy.com/prod/mitsubishi-wd-60737-180-watt-tv-lamp-replacement/q/sellerid/25087312/loc/101/223332719.html

 

 

If this answers your question, please click "Accept", as it is the only way we Experts get paid for our knowledge on the site. Tips and Bonuses are welcome and appreciated!!