How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tim Nolan Your Own Question
Tim Nolan
Tim Nolan, TV Repair Technician
Category: TV
Satisfied Customers: 19454
Experience:  Factory trained TV repair technician. U.S. NAVY trained.
12486280
Type Your TV Question Here...
Tim Nolan is online now
A new question is answered every 9 seconds

the red light on my 42pf9630a/37 tv blinks 7 times, and repeats.

This answer was rated:

the red light on my 42pf9630a/37 tv blinks 7 times, and repeats. There are no bad capacitors(by sight) on any of the circuit boards. Help Please!

Thank you for posting your question on Just Answer! I will be happy to help you with this problem. Can you please give us some more information so I can better answer your questions.

 

-Do you know how to use a meter?

 

Please give me this information and I will be happy to assist you further.

Thank you,

Tim Nolan

Customer: replied 6 years ago.
Yes, I am a Prime Power Technician in the US army, but couldn't find any schematics, or trouble shooting procedures or LED blink codes associated with my television, but I do know how to use a meter, and have one here.

Ok did you check all the fuses on the sustain boards then?

 

What made you change the x sus?

Customer: replied 6 years ago.
The two large capacitors were bulging on the top, and all the forums I read had said that the caps on these boards were cheap, and I know that is the first sign of caps being bad. I did check all fuses that I could see, both with continuity and Ohms readings.When I plug the tv in, the green power light comes on and it clicks twice, and there is a humming sound coming from the center of the PCB, and after the power initially comes on, it's about 5 to 10 seconds(approx) then it goes into the safe mode with the 7 red flashing LED. The typical component that I read about on the PCB is the C8059 & C8060, however there is no visual signs of failure on them, and the entire PCB seems to be powering up. Starting to think that it might be one of the Y boards?

Have you checked the VS and VA voltages?

 

Tim

 

Customer: replied 6 years ago.
No, I did check the voltage coming into the PCB, but not sure how to check the VS or VA voltages(test points), but have seen numerous vs and va dials.

Ok on the large plugs going to the y and x sus board you will see some of them labeled VS and VA what you need to do is put your red lead down one of those pins and your black lead on any of the metal on the back of the panel and set your meter to DC voltage, what do you get?

 

Tim

 

Customer: replied 6 years ago.
The VS started out around 5V, and diminished continually as if I were dischargin the capacitor. The VA started at around 0.67V. That was after it went into safe mode. When I unplugged and plugged it back in, the VA was at around 70V, and the VS went up to 212v going to the X-SUS board, and 216V going to the Y Board. All of course DC measurements, and all disapated when power was removed from the plug.

So would they stay at the 212 and 70 until you unplug it or did they go down by themselves?

 

 

Customer: replied 6 years ago.
The TV went into safe mode(RED LIGHT BLINK of Death.....LOL), and then capacitor discharge. Steady drop off.

If you unhook the cables going from the power supply to the y sus does the tv stay on?

 

Also where did you get the x sus from?

 

Lastly, just to let you know I have to leave for a meeting here in a few mins, if you like we can continue when I get back if you would like immediate assistance you can opt me out and see if any other experts are available to help you.

 

Tim

 

Customer: replied 6 years ago.
I got the X-SUS board from an Ebay seller who gets their components from Brand new out of the box broken screens that couldn't be sold by the MFR. When I unhooked the Y SUS board, the TV stayed on, but screen stayed black. How long will you be gone for your meeting? I am already comfortable with you and would like to continue to deal with you........????

The tv stayed on!? Well thats easy enough lol...well we should have one of three boards bad at this point either the y, the upper or the lower.

 

What you need to do is take the upper buffer out of the tv and then hook the y back up and see if it stays on, if yes then we have a bad upper. If no then you need to put the upper back in the tv and remove the lower, does the tv stay on? If yes then you have a bad lower if no then I believe we have a bad Y

 

You should be able to determine what part in the tv is faulty by doing this now, let me know if you have more questions. I do not know when I will be back but hopefully an hour or 2 at the most...I hope.

 

Tim

 

Customer: replied 6 years ago.
Help wtih removing the Buffer boards. These card cable clips are ridiculous!!!

Sorry...Can you post a picture of the cable area so I can see what ones we are dealing with....there are 3 different possiblities in those philips sets....(if you can post a picture, please click the icon above where you are typing with the green tree on it. This will allow you to upload a picture)

 

 

 

 

Tim

 

Customer: replied 6 years ago.
I figured it out, and got a refurbished one ordered from ebay today. Thanks for all your help! Stellar!!!

Awesome news! let me know if you need anything in the future!

 

Tim

 

Tim Nolan and 2 other TV Specialists are ready to help you
Customer: replied 6 years ago.
Hey Man, I just replaced the Y-main, and the power is staying on, but now the screen is still black???? Please Help!!!!!

Do you have the old X sus?

 

Tim

 

Customer: replied 6 years ago.
YES

Try putting it back in and see what happens, I do not trust your ebay seller that you got the X from...

 

Tim

 

Customer: replied 6 years ago.
OK, STANDBY...LOL

will do

 

Customer: replied 6 years ago.
PUT IT BACK IN AND SAME PROBLEM.....GREEN POWER LED STAYS ON, NO PROTECTION MODE RED LED COMING ON.....BUT STILL BLACK SCREEN

Menu button does not pull the menu up?

 

How are the VS and VA voltages?

 

Tim

 

Customer: replied 6 years ago.
VS HOLDING STEADY @ 207.7
VA HOLDING STEADY @ 70.8

Ok lets try removing the upper and lower one at a time again now that we have a good y...it is possible that we had 2 boards go bad at once and last time when we did the test it wouldnt work because we had a bad y.

 

Let me know.

 

Tim

 

Customer: replied 6 years ago.
WHAT SHOULD I SEE IF ONE OF THEM IS BAD?
Customer: replied 6 years ago.
IT'S THE UPPER Y BUFFER THAT IS BAD.....WTF, I HATE THESE DAMNED TV'S. PRETTY SOON I AM GONNA HAVE A FREAKING COMPLETELY NEW FREAKIN TV....

lol sorry...so when you took the upper out you got a picture on the bottom?

 

Tim

 

Customer: replied 6 years ago.
YES, BUT WHEN I TOOK THE LOWER OUT, AND PUT THE UPPER BACK IN, I GOT NOTHING!
Customer: replied 6 years ago.
IS THERE ANY WAY TO TEST IT AND REPAIR IT MYSELF? THE UPPER THAT IS?

Sorry but no...that board has to be replaced it is not serviceable. Once of those tiny flatpack IC's has failed and cannot be changed.

 

Tim

 

Customer: replied 6 years ago.
THANKS TIM! YOU COULDN'T SHIP ME ONE OVERNIGHT COULD YA.....LMAO

LOL sorry I do not even have one.

 

Tim