How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Joe Your Own Question
Joe, Electronic Tech
Category: TV
Satisfied Customers: 831
Experience:  Over 30 years in electronics, Board Repair, TV's, Gaming,
Type Your TV Question Here...
Joe is online now
A new question is answered every 9 seconds

I have a 50 Toshiba 50HP66 plasma that has sound but no picture.

Customer Question

I have a 50" Toshiba 50HP66 plasma that has sound but no picture. Y-main is known to be good. Power board seems to be putting out correct voltages. No swollen caps anywhere. Anybody with experience with this model and problem with ideas?
Submitted: 6 years ago.
Category: TV
Expert:  Rick williams replied 6 years ago.

Hello friend, Thank you for posting your question on Just Answer! I will be happy to help you with this problem, And possibly help you save on these Labor charges today, So please don't Accept my answer unless you are satisfied,




If so then the issue is the Main,, or logic board (SCALER BOARD)



Customer: replied 6 years ago.

Tried replacing the scaler board. Same problem, no difference. VA, VS, VSCAN Voltages are all good.


Sound is good, no picture at all, screen does not even light up for startup or volume, menu, etc.


Any other ideas?


Expert:  Rick williams replied 6 years ago.
Of course you should see this is the Main board,, then
Customer: replied 6 years ago.
Main board replaced. Still same problem. Re-checked power supply voltages and now the 5V are showing 6.8V coming off the power board. Any other ideas or should I just start selling off the boards that I bought?
Expert:  Rick williams replied 6 years ago.
Are you kidding,, All voltages are good VS VA VSCAN,, new scaler new main board,, the board that says digital pc board,, so your saying you changed everything correct,, except the Panel
Customer: replied 6 years ago.
Yes. Replaced y-main, scaler, main logic board. VS, VA, VSCAN voltages are OK. The only thing I see thats off is the voltages that should be 5V are showing 6.8V off the PSB. All hookups/connections have been triple checked and I still have sound but no video. I've worked on many Plasmas and LCD TV's and never had one stump me like this one.
Expert:  Rick williams replied 6 years ago.

what about VE voltages please tell me all the voltages you read,, the label from the Panel should guide you,, because you never mentioned the VE voltage or any voltages for that matter,, so start now take measurements and tell me what they are,,


read everything on the X- board please

Customer: replied 6 years ago.

Voltages constant from PSB to Y-main to Z to X

VA = 58.1V

VS = 196.2V

VScan = 7.19

5V = 6.44


Vscan is low - should be 12V?

5V is high - should be 5V?


You're going to tell me that the Power Supply is bad right?

Expert:  Joe replied 6 years ago.

If you remove the back you will fine a couple of caps that are bulged and they need to be replace, or you can buy a new power supply at If you want to just purchase the caps, you can get them at

Customer: replied 6 years ago.
Relist: Inaccurate answer.