How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tim's Auto Repair Your Own Question
Tim's Auto Repair
Tim's Auto Repair, Mechanic
Category: Transmissions
Satisfied Customers: 15479
Experience:  I have been rebuilding automatic transmissions for 25 years
14541291
Type Your Transmissions Question Here...
Tim's Auto Repair is online now
A new question is answered every 9 seconds

I believe my transmission range switch is out but not sure,

Customer Question

I believe my transmission range switch is out but not sure
JA: When was your transmission fluid last checked?
Customer: I check it often. My car will not crank at all when I turn on the key. I made sure it was in park, checked the battery and the terminals. My lights will come on and the radio will play but as soon as I try to start the car everything shuts off.
JA: What is the model/year of your Hyundai?
Customer: 2002 Hyundai sonata
JA: Are you fixing your Sonata yourself? What have you tried so far?
Customer: Yes I am. I made sure the battery was good and cleaned all the terminals. I checked all my fuses and made sure I had power going to my fusebox and all.
JA: Anything else you want the mechanic to know before I connect you?
Customer: No
Submitted: 1 month ago.
Category: Transmissions
Expert:  Tim's Auto Repair replied 1 month ago.

Hi, My name is ***** ***** for the delay.
I will do my best to assist you.

Expert:  Tim's Auto Repair replied 1 month ago.

do you hear a click when you try to start?

please explain"My lights will come on and the radio will play but as soon as I try to start the car everything shuts off."

Customer: replied 1 month ago.
There's no clicking when I turn the key. If I have the key in the ignition, all the lights, wipers, the radio, the AC, etc. will come on in the cab. But when I actually try to turn the key to start it, all the electronics in the car shut off until I stop turning the key. There is no clicking noise but there is a faint whine that can be heard near a part that is in the very rear of the engine on the passenger's side.
Expert:  Tim's Auto Repair replied 1 month ago.

ok

will it start with the transmission in neutral?

Customer: replied 1 month ago.
No it will not
Expert:  Tim's Auto Repair replied 1 month ago.

is the noise you hear coming from the starter?

does the lights come back on when you let back off of the switch?

Expert:  Tim's Auto Repair replied 1 month ago.

how and when did this problem first begin?

Customer: replied 1 month ago.
the lights come back on afterwards. No I do not believe it is the starter. It is a black box just above the AC lines in the back of the engine. If you are facing the front of the car it is to the furtherest back and left of the engine compartment. I did not notice any problems with the car before until I tried to start it this morning and its been the same ever since.
Expert:  Tim's Auto Repair replied 1 month ago.

are you sure the battery is up?and not weak?

Customer: replied 1 month ago.
the battery has a charge of 11.84 according to me voltometer and I already checked and cleaned every possible battery terminal and connection
Expert:  Tim's Auto Repair replied 1 month ago.

ok

i can give you the starting system wire diagram..if you want to do some tests/checks.

willthat help you?

Expert:  Tim's Auto Repair replied 1 month ago.

what engine do you have?2.4 or the 2.7?

Customer: replied 1 month ago.
I have the diagrams in my Chilton's manual but they are like a foreign language to me. I will gladly look at them if they will help. I have the 2.4. Would you like to hear about some of the tests I've done already?
Expert:  Tim's Auto Repair replied 1 month ago.

stand by..i may have info that will help you better than the manual you have

Customer: replied 1 month ago.
I tested the continuity between my battery and the starter and there was continuity all the way through. I put the positive probe of my voltomoter against the selenoid wire and the negative probe to the negative terminal on my battery while my buddy was attempting to start the car and it read around 9 volts.
Customer: replied 1 month ago.
There is continuity between my battery and the fuse box so I know it has power, but it didn't register any voltage when I tested the power where my starter relay plugs into the fuse box
Expert:  Tim's Auto Repair replied 1 month ago.

ok

you may have a bad ignition switch itself,,or even a bad starter relay,you wil need to dpo some testing.

PLEASE COPY AND PASTE the link below to your browser, I have uploaded more info on this there.please copy and paste the link below to your main browser[INTERNET EXPLORER ,Chrome or Firefox.]

.

https://www.dropbox.com/s/7vshcvjbc9r5k21/1030-sonata-GENERAL%20INFORMATION.doc?dl=0

.

if the link doesn’t work that way, try it this way

thanks

.

www.dropbox.com/s/7vshcvjbc9r5k21/1030-sonata-GENERAL%20INFORMATION.doc?dl=0

.

If you are satisfied with my answer, Please Rate my answer by clicking the rating button so I can get credit for my work. I’m not always going to be giving you good news, so please don't let this stand in the way of you accepting my answer. .it does not cost you more money and we will still be able to communicate, ,.please understand, i can not see, hear or touch the vehicle and only know what you tell me. Bonuses and positive feedback are appreciated.. if you are not satisfied with my answer, please do not leave bad feed back ,i will gladly opt out and let another expert handle the question. .if i have sent any diagrams, please print them. .sometimes you may need to right click the image [,then save picture as]to save it to your computer so you can open it with your picture program...Please ask if you need more help

Customer: replied 1 month ago.
What do you think of the tests I did on it? Are those signs of anything good or bad?
Expert:  Tim's Auto Repair replied 1 month ago.

those tests tells me that either the relay isnt working,the neutral safty switch is bad,the switch is bad or you have a bad wire from the switch to the relay or to the starter

Customer: replied 1 month ago.
I was reading a thread on here earlier about a guy with a faulty transmission range switch and his problems were very similar to mine. What can you tell me about what it does and how to test it?
Expert:  Tim's Auto Repair replied 1 month ago.

to test it you will need to use the wire diagrams i gave you..

the range sensor only lets the car start in park or neutral,it also turns on the back up lamps when in reverse.

it also tells the computer what gear you have the transmission in

Customer: replied 1 month ago.
I still have trouble deciphering those but I'll give them a good look. I'm going to remove my starter, selenoid and starter relay and have them all tested tomorrow.
Expert:  Tim's Auto Repair replied 1 month ago.

ok

let me know how it gos

thanks

Customer: replied 1 month ago.
Do you know what that part is that I said was whining when I attempted to start the car? The black box to the very back and left of the engine compartment?
Expert:  Tim's Auto Repair replied 1 month ago.

are you talking about the relay box?

Customer: replied 1 month ago.
It isn't the box with all the fuses in it if that's what you mean. It is right behind where the shocks are mounted on the passenger side. It has a cable running from it to the throttle. It is black and shaped like a rectangle with a circle shape on top of it.
Expert:  Tim's Auto Repair replied 1 month ago.

i think you are talking abou the cruise control module

Customer: replied 1 month ago.
Huh. Maybe I'm hearing it wrong. Where could that whining noise be coming from?
Expert:  Tim's Auto Repair replied 1 month ago.

that i dont know,,i can hear or see it.sorry

Customer: replied 1 month ago.
True. Thanks for the help. I'll get in touch with you tomorrow if I have any questions
Expert:  Tim's Auto Repair replied 1 month ago.

ok

'great

thanks

If you are satisfied with my answer, Please Rate my answer by clicking the rating button so I can get credit for my work. I’m not always going to be giving you good news, so please don't let this stand in the way of you accepting my answer. .it does not cost you more money and we will still be able to communicate, ,.please understand, i can not see, hear or touch the vehicle and only know what you tell me. Bonuses and positive feedback are appreciated.. if you are not satisfied with my answer, please do not leave bad feedback ,i will gladly opt out and let another expert handle the question. .if i have sent any diagrams, please print them. .sometimes you may need to right click the image [,then save picture as]to save it to your computer so you can open it with your picture program...Please ask if you need more help.

Customer: replied 1 month ago.
I tested my starter and relay and both good. My battery shows 11.5 volts. I tried a new transmission range switch and it still did the same.
Expert:  Tim's Auto Repair replied 1 month ago.

ok.

if both are good,you may now need to check the wiring

Customer: replied 1 month ago.
I put the starter and solenoid back on. I cleaned and scrubbed every single point that was associated with the battery, including the ground. I put everything back together, and tried to fire it up. When I did, there was a loud clicking noise and the dash lights dimmed. I went and took the starter relay out and when I tried to start it everything shut off like before. Put the starter relay back in and it does the loud clicking when I try to start it
Expert:  Tim's Auto Repair replied 1 month ago.

.