How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08, ASE Certified Technician
Category: Transmissions
Satisfied Customers: 21439
Experience:  Chrysler/Dodge/Jeep master tech ASE Master and Advanced Certified, Chrysler/Dodge/Jeep Master Certified, Trans Specialist
Type Your Transmissions Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

I have a 2004 jeep liberty. When i press down hard on the

This answer was rated:

i have a 2004 jeep liberty. When i press down hard on the pedal there is a 1-2 minute pause. What could this be? Cost to fix.
Customer: replied 11 days ago.
I have these codesECM
P0839 yield switch high
P0700 transmission controller faultTCM
P0706 check shifter signal
P0218 high temp operation activated.
Customer: replied 11 days ago.
Check engine light is on. Does this sound like a transmission rebuild or sensor problem? How can you tell?
Customer: replied 11 days ago.
Transmission fluid flush maybe?

Hello and welcome to JustAnswer!

I'm assuming that the transmission is slipping when you attempt to accelerate, or it's delaying when you put it into gear. There are several things that can cause slipping or a delay but with the P1776 set you may have a sticking solenoid switch valve in the valve body.

Has the fluid level and condition been checked?

Can you describe the exact symptoms?

Customer: replied 8 days ago.
Transmission fluid is brown. Jeep does not seem to have problems shifting into reverse. Is a automatic. I noticed slipping when you accelerate.

Does it happen when the trans is hot but it's fine cold?

Customer: replied 8 days ago.
What do you mean?

Does it slip all the time, only when the trans is hot, or only when the trans is cold?

Customer: replied 8 days ago.

If it only happens when hot then you can try replacing the filter and see if that changes anything. It may be restricting with debris from clutch failure, geartrain failure or lack of periodic maintenance. If that doesn't change anything then the trans will either need to be replaced or rebuilt.

sprinkles08 and 2 other Transmissions Specialists are ready to help you

Related Transmissions Questions