How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Kevin Your Own Question
Kevin, Auto Mechanic
Category: Transmissions
Satisfied Customers: 1362
Experience:  Diagnostic technician
Type Your Transmissions Question Here...
Kevin is online now
A new question is answered every 9 seconds

I started the car and I got a "transmission fault" light

Customer Question

I started the car and I got a "transmission fault" light came on , then it went off, but the time and date was off So I shut the car off for a few minutes and restarted. I did not come back on. After a few hours I went back to start it again and the "transmission fault" light came back on, but went off again. Should I check the battery?
JA: Does the battery look like it's leaking? And does it have a strong smell -- like sulfur?
Customer: No, I don't recall any smell.
JA: What is the make/model/year of your car?
Customer: 2013 range rover sport
JA: Are you fixing your Range Rover yourself? What have you tried so far?
Customer: no I'm a girl LOL
JA: Anything else you want the mechanic to know before I connect you?
Customer: No that's it. Oh it has almost 30000 miles on it
Submitted: 14 days ago.
Category: Transmissions
Expert:  Kevin replied 14 days ago.

Hi I'm Kevin the battery would be my first recommendation . When starting car a high amount of power is used and can if low cause faults within systems like you are seeing . Once car has run for a couple of seconds the battery is being charged and faults dissapear . I would have battery tested before Doing any other tests .

Related Transmissions Questions