How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08, ASE Certified Technician
Category: Transmissions
Satisfied Customers: 21422
Experience:  Chrysler/Dodge/Jeep master tech ASE Master and Advanced Certified, Chrysler/Dodge/Jeep Master Certified, Trans Specialist
Type Your Transmissions Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

I have a 2003 Eclipse Spyder GT that has had a new automatic

Customer Question

I have a 2003 Eclipse Spyder GT that has had a new automatic transmission placed it. But it still has not set yet. So it still jacks. So I have ordered a new computer to place in it. So i am wondering how to program the computer.
JA: How many miles are on the car? Is it the original transmission?
Customer: 133,00 and no the original transmission went out. So I got a new out the box tranny.
JA: Are you fixing your Eclipse Spyder yourself? What have you tried so far?
Customer: I did the 1st time with placing the new tranny in. But after it did not reset after 2 months of driving it normally and driving it in the sportomatic mode. I took it to a trannsmission shop. They looked it over and said everything was perfect when i placed it in. But they ook it out and put it back in. An said after a week or so it set and the computer should set it. by doing what I was doing before. But after a month it still did not set. So I got smart and took the tranny out again and placed it in my friends eclipse spyder that he had sitting for a few years. and it jacked and what not, but after about a week of driving. It stopped and never did it again.
JA: Anything else you want the mechanic to know before I connect you?
Customer: Yes it also while it not being set. if I try rapid acceleration it just redlines then the transmission catches. also the same with rapid breaking .
Submitted: 18 days ago.
Category: Transmissions
Expert:  sprinkles08 replied 14 days ago.

Hello and welcome to JustAnswer!

It sounds like you're describing the transmission slipping. If it disengages under hard acceleration and then engages again that's clutches slipping. If it happens when braking also then I would first suspect that the pump is sucking air due to low fluid level or a filter issue.

Do you know what fault codes are setting in the TCM?

Related Transmissions Questions