How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tim's Auto Repair Your Own Question
Tim's Auto Repair
Tim's Auto Repair, Mechanic
Category: Transmissions
Satisfied Customers: 15826
Experience:  I have been rebuilding automatic transmissions for 25 years
14541291
Type Your Transmissions Question Here...
Tim's Auto Repair is online now
A new question is answered every 9 seconds

When transmission is cold the engine dies immediately when i

Customer Question

When transmission is cold the engine dies immediately when i put it into any gear. When it warms up seems like the problem goes away but still if it is in D it picks up slowly and if I put it into 2 or 1 it picks up speed fine. Codes P0700, P2706, P0871
JA: Does the vehicle have a carburetor?
Customer: its a 2004 Ram 1500 5.7 Memi
JA: Are you fixing your Ram 1500 yourself? What have you tried so far?
Customer: the shop recommended to replace the transmission solenoid module and we did that but problem remains. Interestingly when codes cleared everything works fine but codes coming back and problem start al over again.
JA: Anything else you want the mechanic to know before I connect you?
Customer: i think this is enough
Submitted: 7 months ago.
Category: Transmissions
Expert:  Tim's Auto Repair replied 7 months ago.

Hi, My name is ***** ***** for the delay.
I will do my best to assist you.

Expert:  Tim's Auto Repair replied 7 months ago.

sense you have already replaced the solenoid and from the way you explain..

this sounds as if you may have a bad torque converter

Expert:  Tim's Auto Repair replied 7 months ago.

it sounds as if the lock-up converter isnt unlocking when cold

Customer: replied 7 months ago.
that would not make sense since clearing the codes makes it work fine cold but the code is coming back and problem coming back with it.

Related Transmissions Questions