How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask david craig Your Own Question
david craig
david craig, Auto Mechanic
Category: Transmissions
Satisfied Customers: 2519
Experience:  owner/mechanic at 3D Automotive
4993992
Type Your Transmissions Question Here...
david craig is online now
A new question is answered every 9 seconds

I m in problem with my mazda 3 2004 after change the ATF

Customer Question

hello
i m in problem with my mazda 3 2004 after change the ATF changed
its showing suddenly AT signal on dash meter with a heavy jerking!
but when i just switch on/off at running with N gear this problem gone !
but after few minutes it come again if speed is slow less 40 kmph
but this problem not shown when car in high speed
Submitted: 8 months ago.
Category: Transmissions
Customer: replied 8 months ago.
please see this video i made this for your help
https://www.youtube.com/watch?v=84LecGn20Wg
Expert:  Chad Farhat replied 8 months ago.

Hi, I'm Chad. Welcome to JustAnswer. I'm reviewing your question and I will be posting your reply ASAP.

Customer: replied 8 months ago.
hello dear !
Expert:  Chad Farhat replied 8 months ago.

hey how are you

have you checked fluid levels ?

have you had a diagnsotic scan done with a mazda or equivalent scanner ?

did the problem exist before fluid change ?

please let me know

Thank You *****
ASE Certified Technician

Expert:  Chad Farhat replied 8 months ago.

I watched video, no sound , i dont see the speedometer moving ,werent you driving it and switching from drive to reverse ?

Customer: replied 8 months ago.
fluid lever fully correctly
and yes i have ant OBD 2 scan tool but not checked yetand no it never happened before !
Customer: replied 8 months ago.
if it shows AT signal the car not move in D gear without acceleration
Customer: replied 8 months ago.
speedometer also stopped work if AT signal shows
Customer: replied 8 months ago.
but i want to tell one thing.. that my mechanic telling me that . have to change gear boxbut i m not agree with that.. cause my car hit easily 180kmph
Customer: replied 8 months ago.
that mechanic not so expert for mazda ...first time i give toyota T-IV fluid but and got this problem and i stop driven my car instantly
then i checked that it has own grade fluid which is MV
Customer: replied 8 months ago.
i changed with MV ATF oil instantly with proper flashing old oil
Expert:  Chad Farhat replied 8 months ago.

it sound more of a valve body ,shifting solenoid sticking ,sometimes after a fluid change it will move debri around and have some debris stuck

also if the speedometer not working this will happen, there vss ( vehicle speed sensor ) if it went bad it will cause this need to check

if the trans was bad internally debrix would be in the fluid

if the scan turn out nothing on the trans module

i suggest another tran fluid change and get another opnion from another shop

Please let me know if you need anything else on it, just reply back & we will continue

If you are good , kindly rate me.

A Positive rating is much appreciated

This post will stay open for you even after you rate me, for you to come back and ask any follow up question you may have on this issue

Thanks You
Chad Farhat
ASE Certified Technician

Customer: replied 8 months ago.
need to change my gear box ?
Expert:  Chad Farhat replied 8 months ago.

i want change it before i test all the above i mentioned .

valve body, run a scan , check wiring , change fluid

Customer: replied 8 months ago.
valve body mean ? can you give me a picture ?
check wiring.. how to do that ?
Customer: replied 8 months ago.
are you here with me please ?
Expert:  Chad Farhat replied 8 months ago.

Remove transmission pan and the access the valve body

I sent you a picture

Testing the wiring , is a long process and needs diagrams and scanner and voltmeter to do that .

sorry it will be hard to tell how to do on here , sorry

I will start by scanning it and see if any codes exits

please let me know ,if you need anything else on it .

Thank You *****
ASE Certified Technician

CONTROL VALVE BODY REMOVAL On-Vehicle Removal Warning: Using compressed air can cause dirt and other particles to fly out, causing injury to the eyes. Wear protective eyeglasses whenever using compressed air. Caution: ^ Clean the transaxle exterior throughout with a steam cleaner or cleaning solvents before removal. ^ If any old sealant gets Into the transaxle during installation, of the all pan, trouble may occur In the transaxle case and oil pan. Clean with cleaning fluids. 1. Remove the battery duct and battery cover. 2. Disconnect the negative battery cable. 3. Drain the ATF into a separate suitable container. 4. Remove the under cover. 5. Remove the oil pan. 6. Disconnect the solenoid connectors and GND.

7. Remove the oil strainer.

8. Remove the control valve body installation bolts as shown in the figure, then remove the control valve body component as shown in the figure.

9. Remove the accumulators and accumulator springs.

Expert:  Chad Farhat replied 8 months ago.
I m sorry ,there is a delay on here ,when replying between us
It is not like texting ,so it takes few minutes sometimes
Thanks
Customer: replied 8 months ago.
valve body under gearbox in transmission pan ?what to do with valve body ?and i give you picture.. can you tell me? should i change that ? (collected from net)
http://image.prntscr.com/image/4d721cc201954c3492e4060feaf4abed.png
Expert:  Chad Farhat replied 8 months ago.
I would take that plug out and clean the contact ,it looks bad
Valve body needs to be taken out and test the solnods in it,we send them out to another shop to test those .
Customer: replied 8 months ago.
what test should to do with solnods ?
Expert:  Chad Farhat replied 8 months ago.

they should all read 15 ohms or higher

Customer: replied 8 months ago.
how i can check that? they reading 15 ohms ?
Expert:  Chad Farhat replied 8 months ago.

using a voltmeter on the OHM setting and touching the voltmeter leads to the solenoids pins

Customer: replied 8 months ago.
too much issues your showing to me
Expert:  Chad Farhat replied 8 months ago.

what you mean ?

Customer: replied 8 months ago.
dont mind please.. i am not happy with your suggest.. cause here i am not getting proper suggest with you !
Customer: replied 8 months ago.
i was expecting some short and good suggestion
Expert:  Chad Farhat replied 8 months ago.

that is no problem I will open your question for another expert right now and opt out, and they will help you

Customer: replied 8 months ago.
i am really very upset now.. my 18 usd gone in water ?
Customer: replied 8 months ago.
what ?
Customer: replied 8 months ago.
i will be held here ?
Customer: replied 8 months ago.
please reply me.. can i get money refund ? by your moneyback guarantee ?no problem you can keep my $5 but please refund me $13really its not helpful for me
Customer: replied 8 months ago.
hello Mr.Chad
Customer: replied 8 months ago.
no response now ???
Customer: replied 8 months ago.
Scan tool showing TCM problem
Expert:  david craig replied 8 months ago.

Hi im David, what code is coming up for the TCM?

Customer: replied 8 months ago.
Can you please tell me where is TCM device on Mazda 04 ?
Expert:  david craig replied 8 months ago.

allow me to get that information for you. thank you.

Customer: replied 8 months ago.
Hello
Customer: replied 8 months ago.
Code showing P0031 powertrain dual and air metering
Expert:  david craig replied 8 months ago.

it sits on top of the transmission

Expert:  david craig replied 8 months ago.

P0031 DTC trouble code may be caused by one or more of the following: A short or open in the heater circuit in the sensor A failed O2 sensor heater Wiring/connectors broken/frayed leading to sensor and/or relay

the p0031 is not related in any way to the transmission issue.

Customer: replied 8 months ago.
No dear it's not there I checked ! Btw obd scan telling now
Customer: replied 8 months ago.
need to change air sensor ??
Expert:  david craig replied 8 months ago.

yes, you need to replace the b1s1 oxygen sensor

Customer: replied 8 months ago.
B1s1 mean ???And then what is the reason that turn on AT signal ??
Expert:  david craig replied 8 months ago.

Bank 1 Sensor 1 ...its the forward oxygen sensor. it has nothing to do with turning on the AT light. its 2 different issues. does your scan tool have the capabilties of reading the transmission for fault codes?

Customer: replied 8 months ago.
I am telling you that fault code . This TCM code show only when it's turn on AT sign
Customer: replied 8 months ago.
Can you please give me the o2 sensor location plz ??
Expert:  david craig replied 8 months ago.

what is the code number for the tcm fault???

Expert:  david craig replied 8 months ago.

the b1s1 is #1 in the image, it will be the one on the left in the middle of the catalytic converter.

Customer: replied 8 months ago.
Is that sensor behind the engine ?
Expert:  david craig replied 8 months ago.

yes, thats the sensor.

Customer: replied 8 months ago.
But it's not a problem for me now my problem is that AT ..
Customer: replied 8 months ago.
You can check past chats
Expert:  david craig replied 8 months ago.

I need to know the code number that the scan tool is showing for the transmission. if you cannot provide that to me I will not be able to help you.

Expert:  david craig replied 8 months ago.

If you can not get the codes then I will opt out. I am not going to guess what wrong. that is neither beneficial to you nor I. good day sir.

Expert:  Peter Bagley replied 8 months ago.

Hello and welcome to just answer ans allowing me to assist you. I see your having a bit of problem? after reviewing the info above I'm addressing that you inadvertently installed the wrong fluid at one point. sorry to say even though you had replaced it and flushed it with new proper fluid the damage is done to the internal parts of your transmission, you can diag all you want but in the end you will not find a quick fix other then either rebuilding the transmission or replacing it .as for those other codes and problems they wont effect shifting other then the trany codes which area result of the damage the wrong fluid caused. Sorry of being the bearer of bad news but that's the short story of your problem.if you have any further need of assistance I'll be happy to do so.

Customer: replied 8 months ago.
u r right . Now what to do ??
Customer: replied 8 months ago.
Hello .. I don't think that I need to change trans.. Cause my trans can easily hit 180 kmpsIs there any bypass solution ??
Expert:  Peter Bagley replied 8 months ago.

Well that's my synopsis due from experience but if you want another opinion I'll opt out good luck.

Customer: replied 8 months ago.
Btw may be Mazda 04 don't have TCM , right ??
Customer: replied 8 months ago.
Here machanics are not too smart for Mazda, they telling me to changed trans.. But I know AT problem won't go after change trans. May be any wiring problem or not . Can't understand :(
Here machanics playing Guess game with me
Customer: replied 8 months ago.
you there ?
Customer: replied 8 months ago.
24 hrs gone and no update ?
Customer: replied 8 months ago.
hello anybody there ?
Customer: replied 8 months ago.
No response !!!!
Expert:  david craig replied 8 months ago.

replace your transmission................

Customer: replied 8 months ago.
transmission replacing will not a solution of this matter i thinkand why you telling me that.. my car speed can easily hit 180 kmphits just happened when slowing down or coming to a stop