How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka- Moose) Your Own Question
Chris (aka- Moose)
Chris (aka- Moose), Technician
Category: Transmissions
Satisfied Customers: 44488
Experience:  16 yrs. experience with auto, manual, & CVT drivelines
2499435
Type Your Transmissions Question Here...
Chris (aka- Moose) is online now
A new question is answered every 9 seconds

Cadillac Deville DHS: 2000 Cadillac cluster says car is in

Customer Question

2000 Cadillac cluster says car is in D position and car wont start. i can move the column shifter uop and down in gears but cluster wont show any other postion
Submitted: 7 months ago.
Category: Transmissions
Expert:  Chris (aka- Moose) replied 7 months ago.
Welcome, I'm Chris (aka Moose). I normally log in after 3 pm central. Please make sure to let me know exactly what is needed from me so I can provide EXCELLENT 5 STAR service. I believe I can help on this concern but I see you have been waiting a while. So I need to first off confirm your still wanting or needing help.
Customer: replied 7 months ago.
Yes I still need help
Expert:  Chris (aka- Moose) replied 7 months ago.
Working on your concern now.
Customer: replied 7 months ago.
Ok thanks and is a digital cluster
Expert:  Chris (aka- Moose) replied 7 months ago.
Do you own a scan tool or a digital volt ohm meter?
Customer: replied 7 months ago.
I have a scan tool and a volt meter, when I try to connect, it won't
Expert:  Chris (aka- Moose) replied 7 months ago.
The scan tool will not communicate or will not even power up?Are you able to unplug the PCM to do some wire testing there?
Customer: replied 7 months ago.
It won't connect and I can try tomorrow
Expert:  Chris (aka- Moose) replied 7 months ago.
Lets unplug the PCM. At connector 2, locate:pin 12 yellowpin 41 whitepin 11 graypin 13 black/white Lets now test the shifters signal to the PCM.Black/white should be grounded only in PR32Gray D321White PN31Yellow RND3 If you get those results that narrows this issue down to the PCM for the starting issue and the PCM or instrument cluster for it always showing D. Can you do this test and report back. If needed I can tell you how to bypass it and start the vehicle but I can not confirm how the trans will work if the PCM is always showing drive. -------------------------------------------------------------------------------------On your screen at the top you should see a rating 1-5 stars and a green submit button. Please make sure to select one and press submit. I am not compensated by the website unless a customer rates. Rating only pays me from the deposit you have already made, it does not charge you more, nor close the post. Also all follow ups are free and welcome.Thanks Chris
Customer: replied 7 months ago.
Ok I will check tomorrow since I live in Ga
Expert:  Chris (aka- Moose) replied 7 months ago.
They do not have lights in GA, I thought running water in the house was the only southern issue. Just kidding I am in TN.
Customer: replied 7 months ago.
Haha if I only had the energy right now to even stress myself out on that Cadillac
Expert:  Chris (aka- Moose) replied 7 months ago.
Talk to you tomorrow.
Customer: replied 7 months ago.
I'll check it out tomorrow because I had to work today but am I checking for just ground at those wires or also a certain voltage
Expert:  Chris (aka- Moose) replied 7 months ago.
Your just checking for ground on these wires only in the gears I mentioned.
Customer: replied 7 months ago.
Ok so I pretty much checked those pins with my volt meter set on 20/v it's a regular $12 meter. I'm getting .00 at those pins or am I suppose to set it on ohms??
Customer: replied 7 months ago.
Ok so I set it on ohms and I have ground at all the points you told me to check
Expert:  Chris (aka- Moose) replied 7 months ago.
You do check it for ohms testing each wire individually going through each gear to confirm the wires are ONLY grounded in the gears I mentioned prior. If that test passed then the wiring and range sensor are fine. That leaves the PCM or instrument cluster, 95% likely the PCM to blame. A scan tool would be needed to continue the diag on the shifter position shown wrong.
Customer: replied 7 months ago.
Would the scanner read even if the dash shows its in drive
Customer: replied 7 months ago.
I have an actron scanner
Expert:  Chris (aka- Moose) replied 7 months ago.
As long as your scanner can access all modules and look into the inputs and outputs of the moduels your tool would then work.
Customer: replied 7 months ago.
Ok because I was having trouble connecting to the computer with my scanner
Expert:  Chris (aka- Moose) replied 7 months ago.
A data link connector issue can be a concern with the power and ground to the DLC or the communication wires to the PCM, the PCM powers and grounds, or the PCM.
Customer: replied 7 months ago.
If I get another pcm used, do I have to have it reprogrammed??
Expert:  Chris (aka- Moose) replied 7 months ago.
Yes PCM programming is required with a PCM replacement.
Customer: replied 7 months ago.
I switched out the computer with another from the same year make model but it still confuses me why the cluster still shows its in the d position
Expert:  Chris (aka- Moose) replied 7 months ago.
On the 30th I wrote this "You do check it for ohms testing each wire individually going through each gear to confirm the wires are ONLY grounded in the gears I mentioned prior. If that test passed then the wiring and range sensor are fine. That leaves the PCM or instrument cluster, 95% likely the PCM to blame. A scan tool would be needed to continue the diag on the shifter position shown wrong." Was a scan tool used to finish the diag prior to assuming the PCM was to blame?
Customer: replied 7 months ago.
Yes I tried the scan tool and it powers up when plugged in but says unable to connect
Expert:  Chris (aka- Moose) replied 7 months ago.
Did you OHM test the communication wires from the DLC to the PCM to see if they were broken or shorted causing no communication?
Customer: replied 7 months ago.
Didn't check that but I will
Expert:  Chris (aka- Moose) replied 7 months ago.
Thanks, ***** ***** up to date.
Customer: replied 7 months ago.
Hey I'm back, I actually gave you the wrong info by mistake. So the actual problem is the cluster does NOT show the line that moves when you're in prnd321. It's a line like this _ that's usually under them to let me know what gear I'm in
Expert:  Chris (aka- Moose) replied 7 months ago.
So the ONLY problem with the car is that line. Everything thing else works, correct?
Customer: replied 7 months ago.
Also I mentioned the data link won't connect with my scanner but it will power up the scanner. Everything works and also I noticed the e brake doesn't pop up like it use to when taken out of park and of course car won't start. I did notice a small square box close to the dlc I'll take a picture of it
Expert:  Chris (aka- Moose) replied 7 months ago.
Thanks for the update. I do not know what that box is. I will opt out and remove myself from the conversation. Maybe another can help.
Customer: replied 7 months ago.
Do you know anything about why the line from under the shift indicators on the cluster is not showing???
Customer: replied 7 months ago.
Thanks hopefully I can get an idea of what's going on