How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Wilson Your Own Question
Daniel Wilson
Daniel Wilson,
Category: Transmissions
Satisfied Customers: 4679
Experience:  Owner at DJ Wilson
65405794
Type Your Transmissions Question Here...
Daniel Wilson is online now
A new question is answered every 9 seconds

Truck won't shift. No speedometer no line under PRND

Customer Question

Truck won't shift. No speedometer no line under PRND
Submitted: 1 year ago.
Category: Transmissions
Expert:  Daniel Wilson replied 1 year ago.

Hi Jordan, My name is***** will be glad to try to help. With someone under the truck move the shifter with the brake on for safety to see if the shift lever is moving on the transmission. If not take a close look at the linkage and shift cable that it is either broken or became disconnected. Let me know

Customer: replied 1 year ago.
Truck drives. But o. Take off is very laggy. I have park reverse and a drive gear. Doesn't shift while driving just revs way high and does maybe 30mph.
Expert:  Daniel Wilson replied 1 year ago.

Thanks for the update, Check for burnt and discolored oil indicating internal problems. Also check the filter and bottom of the transmission pan for metal.friction material and debris.

Customer: replied 1 year ago.
Filter and fluid changed. This all started after having the ecm & tcm flashed and reprogrammed. Any possibility of a bad Neutral Position Sensor.
Expert:  Daniel Wilson replied 1 year ago.

If this was present only immediately after the reflash then the problem is very likely related to the software issues unless there is a harness or module problem. Are there any fault codes or communication troubles with the modules?

Expert:  Daniel Wilson replied 1 year ago.

Possibility of a faulty speed sensor since you are having speedo problems and this is related to the proper shift points etc. TCM and ECM read speed signal

Expert:  Daniel Wilson replied 1 year ago.

Let me know

Customer: replied 1 year ago.
The check engine and service brake system and abs light came on. No previous problems prior to flash and reprogram. The dealership said the ecm was fried so they couldn't reprogram but said everything was fine. They are not much help.
Customer: replied 1 year ago.
This is the paper they gave me.
Customer: replied 1 year ago.
Is that common with getting the ecm flashed.
Expert:  Daniel Wilson replied 1 year ago.

Thanks for the update. That is actually the procedure that will uncover an ECM that has internal hardware problems if it will not take a successful reflash. The ECM and TCM need to communicate, Did you replace the ECM yet?

Customer: replied 1 year ago.
Not yet.
Expert:  Daniel Wilson replied 1 year ago.

Sounds like the ECM due to an incomplete reflash is not communicating all the Data between the TCM and is what is causing your problems unfortunately

Expert:  Daniel Wilson replied 1 year ago.

The two modules need to pass information between each other for engine speed, road speed, gear position, etc

Customer: replied 1 year ago.
Ok I'll let you know when I replace that.
Expert:  Daniel Wilson replied 1 year ago.

Can you get ahold of a test ECM from a salvage yard?