How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Transmissions
Satisfied Customers: 22114
Experience:  Chrysler/Dodge/Jeep master tech ASE Master and Advanced Certified, Chrysler/Dodge/Jeep Master Certified, Trans Specialist
9825021
Type Your Transmissions Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

I have an 05 VW Jetta GLI 1.8T 5 SPD Auto that I have been

Customer Question

I have an 05 VW Jetta GLI 1.8T 5 SPD Auto that I have been experiencing transmission issues with. For quite some time my reverse slowly got worse and worse and seemed like it only happened when the tranny as cold till it quit all together. I took it to a good garage and they determined fluid was adequate and tranny works when you unplug the TCM putting it in limp mode. He told me not to let anyone else tell me it was the transmission but either the TCM or the internal wiring harness. Well a new issues has arose. When in drive if I let off the gas to make a turn and then re accelerate it seems like the car comes out of gear and goes into neutral until it shifts hard into a lower gear and the car revs real high, but if I take my foot off the gas and let the rams drop it shifts fine. Also if I shift it using the manual Tiptronic side it has no issues when shifting. I cannot get a wiring diagram to check currents and all and the VW Dealer said they have replaced a few valve bodies on those cars but cannot guarantee that will fix it and that part is $1100.00. Sooooo my questions are who has come across this before? What is it that needs replaced without a trial and error of expensive parts? Who has a wiring diagram for the GLI 5spd AUTO tranny and 1.8T motor? What should I do next? Also do you know how to reconnect the TCM plug cause I struggled for 20 minutes this morning and couldn't get it.
Submitted: 1 year ago.
Category: Transmissions
Customer: replied 1 year ago.
I am looking for the correct wiring diagram for my car as well that is required too!
Expert:  sprinkles08 replied 1 year ago.

Hello and welcome to JustAnswer!

It's almost unheard of for an electrical issue to cause a loss of reverse, especially if it progressed over time. The disengaging you're experiencing would usually be caused by a valve body issue or low fluid allowing the pump to suck air.

With the TCM plugged in and allowing the car to operate normally what fault codes are setting?

Customer: replied 1 year ago.
I don't know of any as of yet. We had the battery disconnected this week so everything was cleared. We'll be checking for codes on Tuesday. Do you have access to the correct wiring diagram for my car? I will be happy to update you with codes.
Expert:  sprinkles08 replied 1 year ago.

I do have all wiring and service information.

If the problem is electrical then there is almost no chance of a fault code setting. The first step will definitely be to check for codes if it wasn't done so already.

Customer: replied 1 year ago.
I am still waiting to get back in to be able to scan for fault codes. I won't be able to provide a rating until I have scanned for codes and been able to update you and take it from there. Also one of the things I requested was the correct wiring diagrams which you said you have. What will it take besides checking for codes to get those?
Expert:  sprinkles08 replied 1 year ago.

I can answer any specific questions but I'm unable to post directly from the service information due to copyright.

Related Transmissions Questions