How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka- Moose) Your Own Question
Chris (aka- Moose)
Chris (aka- Moose), Technician
Category: Transmissions
Satisfied Customers: 1589
Experience:  16 yrs. experience with auto, manual, & CVT drivelines
2499435
Type Your Transmissions Question Here...
Chris (aka- Moose) is online now
A new question is answered every 9 seconds

We had the coolant in trans problem. Changed the

Customer Question

We had the coolant in trans problem. Changed the transmission and radiator but used the old valve body. Changed the solinoids and cleaned and resealed the Tcm. During the road test the trans worked fine No slipping as before just would not advance to 4th gear and would not backup sometimes. Because everything was cleaned in the valve body and the solinoids were changed I naturally assumed the tcm was bad. I found a company in Florida that sold them Ordered one and replaced it Now it would not start at all. I called the company and they sent me another one but it still won't start. I'm getting a u1000 u1001 codes. I've checked all the grounds and tcm connections I even pulled the tcm out and checked all the wires in the harnesses and connectors It's getting 12 volts to the plug at the transmission also the display on the dash that shows the gear is blank and it was fine with the old tcm. Please help
Submitted: 9 months ago.
Category: Transmissions
Expert:  Jay replied 9 months ago.

Hello my name is ***** ***** thank you for your question.

The TCM is part of the Valve body. When you get cross contamination, the TCM is one of the first things that start to go. The Tcm for your issue is most likely damaged due to the cross contamination. You would need to replace the valve body if there is no communication with the TCM. The U1000 and U1001 is a indication of Control unit failure or communication. CAN system check would verify if the TCM is the issue.

If you changed the Transmission, why did you use the same valve body? You only run risks of damaging the transmission??

Let me know

Related Transmissions Questions