How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Transmissions
Satisfied Customers: 22127
Experience:  Chrysler/Dodge/Jeep master tech ASE Master and Advanced Certified, Chrysler/Dodge/Jeep Master Certified, Trans Specialist
9825021
Type Your Transmissions Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

05 kia rio trans wont start from 1st gear and no overdrive,

Customer Question

05 kia rio trans wont start from 1st gear and no overdrive, changed both speed sensors and safety nuetral swictch
Submitted: 1 year ago.
Category: Transmissions
Expert:  sprinkles08 replied 1 year ago.

Hello and welcome to JustAnswer!

It sounds as if the trans is in limp in. When the trans controller sees an issue it thinks can cause damage or thinks it doesn't have complete control then it will lock you in a single gear.

There are many things that will cause the trans to go into limp in including the range and speed sensors, but it could also be a solenoid issue, wiring, an internal trans problem, or the trans controller itself.

The first step in diagnosing the problem will be to use a scan tool or code reader to see what fault codes are setting in the TCM, and then testing will need to be done from there to determine exactly what is going on.

Customer: replied 1 year ago.
No code now, I told you I changed the speed senors before that yes code now no codes, is there a way to take it out of limp mode? so far no help.
Expert:  sprinkles08 replied 1 year ago.

If the trans is in limp in there are fault codes set. The reason the trans goes into limp in is because there are fault codes set. If your trans is staying in a single gear then either the TCM isn't functional (there would be TCM communication codes stored in other modules), or the TCM has set fault codes because of a failure it has seen.