How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka- Moose) Your Own Question
Chris (aka- Moose)
Chris (aka- Moose), Technician
Category: Transmissions
Satisfied Customers: 44403
Experience:  16 yrs. experience with auto, manual, & CVT drivelines
2499435
Type Your Transmissions Question Here...
Chris (aka- Moose) is online now
A new question is answered every 9 seconds

2006 Mazda 3 - 2.3L Transmission Issue - Trans runs &

Customer Question

2006 Mazda 3 - 2.3L Transmission Issue - Trans runs & shifts fine - 167,000 miles - 2 times now it has thrown out code 0101 with a AT dash light. First time it fixed itself and we cleared code 0101. Now, the second time, it has the AT light on and Ck Eng
light and it put the car into "limp" mode in 3rd gear. I am assuming we need a Automatic Transmission Control Module and they have to be programmed by a shop.
Submitted: 11 months ago.
Category: Transmissions
Expert:  Chris (aka- Moose) replied 11 months ago.

Welcome, I'm Chris (aka Moose) I'm an independent contractor here at Just Answer.

P0101 is a MAF sensor code that most often means the MAF sensor is dirty or needs to be replaced. This warning would not turn on the transmission light, just the engine light. So that means there are more codes stored and a better scan tool is needed to get them to diagnose the transaxle issues.

Thanks for asking your question and letting me try to help you.

You should see a rating screen if I have posted an answer, not for an info request.

Your rating is my feedback. If I don't get feedback from customers, I will not be able to continue helping customers here.

Rating me good, bad, or not rating at all does not effect the fee you have paid nor does it close the post.

Follow up/Reply as many times as needed.

Customer: replied 11 months ago.
Thanks for responding Moose. I work with Doug a lot on this forum - you guys are great. It was a U0101 code I believe (car at college with kid - we interrogated it a few days ago) and it said on my code reader it was a transmission code. I read the code was TCM lost communication.
Customer: replied 11 months ago.
My son confirmed it did say transmission code. U0101 - Lost communication with transmission control module.
Customer: replied 11 months ago.
Hey I do not think I need any help with this as we are pretty sure we have a bad TCM or harness connection. Thank you for responding Moose!
Expert:  Chris (aka- Moose) replied 11 months ago.

Glad you got it resolved.

Expert:  Chris (aka- Moose) replied 11 months ago.

I like to stay in contact with my customers that appear not pleased, still working on the concern, or have not rated yet. I assume you were not pleased with my help. I hate that you have spent money to get an answer but left not happy. Can you tell me why, or can I help more. If its more help you need just reply and we can pick up where we left off.

Thanks Chris

Customer: replied 11 months ago.
I have had a lot of auto fixes on this web site Moose. I am an aircraft tech for United Airlines so I usually just need bump in the right direction. I simply received no help on my question on this one. I stated that I had a U0101 code. You graciously answered but with the wrong diagnosis for a P0101 code. I never got a response from anyone on the P0101 code and I troubleshot it myself online. No big deal.
Customer: replied 11 months ago.
Sorry - last line I meant to say I never got a response on the U0101 code and I troubleshot it myself online.
Customer: replied 11 months ago.
Again...I have a U0101 code. 2006 Mazda 3. This code mean lost communication with the TCM. This could be the TCM itself or the wiring to it but on these newer cars wiring harnesses and connectors do not go bad very often in my opinion. My decision now is to buy a TCM for $500 or not. I have disconnected its connector and everything looks clean and secure. I may buy a rebuilt one for $299 plus a core charge assuming my wiring is fine. That is my specific dilemma that no one has commented on.
Expert:  Chris (aka- Moose) replied 11 months ago.

I cannot tell by your comments if you have got it figured out and need no help or if you still want or need my help.

Related Transmissions Questions