How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gary Your Own Question
Gary
Gary, ASE Certified Technician
Category: Transmissions
Satisfied Customers: 15689
Experience:  25 years GM master tech
19513769
Type Your Transmissions Question Here...
Gary is online now
A new question is answered every 9 seconds

My Chevy truck with 45K miles (2003 truck) just started

Customer Question

My Chevy truck with 45K miles (2003 truck) just started "hard" shifts from 1st to 2nd and 2nd to 3rd this week. Otherwise the transmission works fine. This truck is pampered, so abuse is ruled out. I do however pull a race car in a 48 foot trailer. What might be the cause? I service the truck every 5K miles, but nothing done to the tranny
Submitted: 1 year ago.
Category: Transmissions
Expert:  Gary replied 1 year ago.

I am sorry your having this problem

does the check engine light ever come on ?

do you know if there are any codes in the computer at all ?

does this truck have any aftermarket programmers or add ons ?

when was the last transmission fluid flash and filter changed on this transmission ?

Customer: replied 1 year ago.

No engine check light

Don't know about codes

As built configuration, and never had any programmer

Trans fluid not changed since built in 2003 (45,000 miles!)

This truck model known for electrical connection issues, and once when 400 miles only, the connector between the computer and tranny malfunctioned. Had to have Chevy pick it up on a flatbed and repair.

Expert:  Gary replied 1 year ago.

does the gear indicator ever flash in the dash or shut off ?

we have had bad park neutral switches cause this problem and even just some sediment rolling out in the fluid in the valve body cause this type of issue and a few with updating the programming in the ECM and TCM would correct this issue

with no light on and it never has an issue of it loosing a gear or acting like neutral the common ignition switch and TCM failures or wiring from the TCM to the transmission should not be your issue

Related Transmissions Questions