How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask ebrock63 Your Own Question
ebrock63
ebrock63, Repair shop manager and tech
Category: Transmissions
Satisfied Customers: 29975
Experience:  Over 25yrs experience as Shop manager and tech
3195632
Type Your Transmissions Question Here...
ebrock63 is online now
A new question is answered every 9 seconds

I have 2011 suzuki kizashi with cvt auto trans in morning

Customer Question

I have 2011 suzuki kizashi with cvt auto trans in morning when cold drives and shifts fine after about ten mile or so will not go over 20 mph like in limp mode suzuki dealer said bad trans replaced transmission with used trans form low mile 2011 kizashi that was tested came out of running car have same problem ??
Submitted: 1 year ago.
Category: Transmissions
Customer: replied 1 year ago.
just checked codes P0741 Torque converter CKT PERF/Stuck off ,Pressure control sol Bckt perf/stuck off code p0776
Expert:  ebrock63 replied 1 year ago.
HI,
I am sorry that you have not been helped yet. I just came online and saw your question
Ok, we need to find out if the solenoids and valve body were replaced or are the originals. It sounds like either they are faulty or possible have some debris restiction in the valve body. I would pull the valve body and clean it out thoroughly to start with
Customer: replied 1 year ago.
Eric if you read what I said replaced trans both trans having same problem first trans we cleaned valve body with no help also new trans has it solenoids and valve body not from old trans ?
Expert:  ebrock63 replied 1 year ago.
HI,
I did read it, but I have seen people get trannies without the valve body and use their original, so I do need to ask those type of questions.
If new solenoids are not defective, then wiring should be checked for being crimped or broken during transmission installation and if ok, then replace the tcm