How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka- Moose) Your Own Question
Chris (aka- Moose)
Chris (aka- Moose), Technician
Category: Transmissions
Satisfied Customers: 44487
Experience:  16 yrs. experience with auto, manual, & CVT drivelines
2499435
Type Your Transmissions Question Here...
Chris (aka- Moose) is online now
A new question is answered every 9 seconds

I gave your advise to my shop and they checked it out. They

Customer Question

I gave your advise to my shop and they checked it out. They only found a small amount of transmission fluid on the connector going in to the transmission, but after cleaning it and leaving it disconnected it only ran for 30 mins and gave the "no bus" error
on the odometer. Any other suggestions ?
Submitted: 1 year ago.
Category: Transmissions
Expert:  Chris (aka- Moose) replied 1 year ago.

Can you feel me in a little more on the past, and present issues and all the repairs done so far?

Customer: replied 1 year ago.
I didn't have a transmission issue. Ed had replied to my first question regarding repeated PCM failures and had me check the harness going into the transmission. Thanks
Expert:  Chris (aka- Moose) replied 1 year ago.

Thanks, ***** ***** does the PCM last?

When it fails does all of it fail or just certain parts of it?

Have you opened one to see what it looks like inside?

Customer: replied 1 year ago.
This all started with a loose connection on the pc card, the center connector on the pcm. The shop replaced the pcm and all was well for 6 months and then it went out again, however, it was not the same symptoms as the first one(NO BUS on the odometer, all gauges dead on the dash). When the second died it still had live gauges and no change in the odometer as far as error reporting. The shop replaced it again and the third lasted 2 months and died with error message on the odometer and all gauges dead. They got a new pcm and it lasted 30 mins. and no bus popped back up. The shop has sent the pcm to the rebuilder for examination as to the area in which it failed so they can get an idea as to where to check next. That is still pending, All of the checks performed by the shop as required by the rebuilder come in as good.
Expert:  Chris (aka- Moose) replied 1 year ago.

I do not believe I can figure this out not in person with that extra info. I will opt out and let another help.