How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Automotive Mechanic
Category: Transmissions
Satisfied Customers: 24726
Experience:  GM and Mercedes vehicle technician.17 years experience.
14928985
Type Your Transmissions Question Here...
Pete is online now
A new question is answered every 9 seconds

02 2500 4x4 duramax allison 1000 after not using

Customer Question

02 2500 4x4 duramax allison 1000 after not using for several weeks it was slow to engage in drive .After idling for less than 1 minute it moved and works fine. I pull up to 12000# ***** any problems. I'm guessing converter or internal seal leak.Any chance fluid filter could help? 170 k on truck bought used .No signs of mods or abuse.
Submitted: 1 year ago.
Category: Transmissions
Expert:  Pete replied 1 year ago.
My name is ***** ***** I am a professional here at Just Answer. I noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.
This can be a fault with the torque converter or possibly even the transmission fluid pump causing this fault here.I would have the transmission checked/tested to locate which is the cause here and repaired from there.In some cases a simple transmission fluid change/flush can correct this as well.
Thanks Pete