How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tim's Auto Repair Your Own Question
Tim's Auto Repair
Tim's Auto Repair, Mechanic
Category: Transmissions
Satisfied Customers: 15483
Experience:  I have been rebuilding automatic transmissions for 25 years
14541291
Type Your Transmissions Question Here...
Tim's Auto Repair is online now
A new question is answered every 9 seconds

Chevy Camaro: I just got my clutch replaced today. I drove

Customer Question

I just got my clutch replaced today. I drove it and there was a chirping sound until I touched the clutch pedal and the chirping would stop. I pulled into my house and all the sudden it was hard to get into gear then wouldn't go into gear at all. It will only go o to first and second gear with engine off. But barely. Its an 82 camaro with a 350 and a Muncie 4 speed. The mechanic had the tranny opened up while they replaced clutch to check everything any ideas what happened? This was a brand new clutch just installed.
Submitted: 1 year ago.
Category: Transmissions
Expert:  K. Wiggins replied 1 year ago.
did the replace the release bearing when doing the clutch?
Customer: replied 1 year ago.
They said they out a kit in resurfaced flywheel. Its a mechanical clutch. Weird thing is this morning went out and now it's working again. Doesn't make sense...
Customer: replied 1 year ago.
Its like when it got warm it didn't work. Now it does. It wouldn't go into any gear and in reverse it wouldn't go in either but would grind really loud when trying to.
Expert:  Tim's Auto Repair replied 1 year ago.
Hi, My name is ***** ***** for the delay.
I will do my best to assist you
is it full of transmission grease?
Customer: replied 1 year ago.
I don't know...is it sludge or something? They changed tranny fluid and put new gasket in
Expert:  Tim's Auto Repair replied 1 year ago.
ok
so it does have new fluid..
is it still shifting gears good now?
or,is it still acting up when it gets hot?
are you using a hydrolic slave cylinder or do you have a mechanical rod operating the release bearing?
Customer: replied 1 year ago.
I haven't driven it again yet. It is a mechanical clutch. There is no cover plate and I drove on a muddy road but its never done that. The whole thing is baffling. I can't believe how it was that bad to all the sudden fine.
Expert:  Tim's Auto Repair replied 1 year ago.
ok
what may have happened here,,is some nud/gravel or debris had got in between the clutch and pressure plate,,that would have caused it to make the noise and not work properly,,after it sit,the heat of the engine may have dried the mud/debris and it came out when you starter the engine..
you need to put a cover on
thanks